summaryrefslogtreecommitdiff
path: root/dev-ruby/capistrano
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/capistrano')
-rw-r--r--dev-ruby/capistrano/Manifest8
-rw-r--r--dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild48
-rw-r--r--dev-ruby/capistrano/capistrano-3.10.1.ebuild40
-rw-r--r--dev-ruby/capistrano/capistrano-3.10.2.ebuild40
-rw-r--r--dev-ruby/capistrano/files/capistrano-2.15.5-sudo-cleanup.patch12
-rw-r--r--dev-ruby/capistrano/metadata.xml12
6 files changed, 160 insertions, 0 deletions
diff --git a/dev-ruby/capistrano/Manifest b/dev-ruby/capistrano/Manifest
new file mode 100644
index 000000000000..b9838007f0c6
--- /dev/null
+++ b/dev-ruby/capistrano/Manifest
@@ -0,0 +1,8 @@
+AUX capistrano-2.15.5-sudo-cleanup.patch 656 BLAKE2B 06c0d83cf2b20337d7692ca3286a6ab8fb3797d67d81ee3498a5cd49f37d94458d19afda1eebc4904c5209809ab869087cd6568af1a4c89aba1b2a2826226fb5 SHA512 846f9c25b1c7806d082ec73faa2b5b9d4b6be285a33acf1d98dc36b9eddab54d664d915c3bab1da28fa2d86225fb1619fd746354cd605b8e3e8a5d0a05cfb96f
+DIST capistrano-2.15.5.gem 132096 BLAKE2B bbaa6bd482cf9bbe7aa01540aa5dab3f32401ffa1476d9057bb8ad420194f1ab2c32d8e744d7c982ebece5c4b5369133dc8378b7adf54c78732f9cb249db2a9e SHA512 10168080c7481ec6fc6f918ac90a3b1ce8f2b36f77411375e33cc915b02d5196ab061ac47e767edd724c82cffd1c2ad0a23ba1f0519cf1f2aae5b429167b19ff
+DIST capistrano-3.10.1.gem 77824 BLAKE2B 548c86c0740703a5b0b92890806411221ea7a9942776d88fc999ce998e3cf5842d809e293d05111ce44cb849719900c7335c43d3795d7147688d48d53a19a133 SHA512 6f3f11498d26c426da740873022767ded44e1be1aeadddd01772d1a5c43dcf2589d5cf2279625470e2e2733d60d3ec865a39640ad4a14b2ef9a64b3da2da579b
+DIST capistrano-3.10.2.gem 78336 BLAKE2B 782cf09f810fd91f4878e126c12d57d19b75c1ccdf3dfee7b2078904743bf51047d1f948e64e6c41460fdaf0a3a9e5a2b646bd6a797f8ce97bc29fab9ca9c533 SHA512 a7eadcd0b949baab2d6ad09c2243f71ec803f85b5c3cf455068d3b0889be30d0f6bbee4ef0bdf90b9c7ec6c3e01886d350fd8a70824366383f7dcc49f0a8c92e
+EBUILD capistrano-2.15.5-r2.ebuild 1246 BLAKE2B 68b68c43b731400c28bf0882f10f244bcff22c5c866688e4541426944c3ed3674e89cd4115b04a72ee8fd3a3eca0e189b7ff7fcc47dee3fd9c253441b9764c8e SHA512 40ed9abea01fdd7633de6a1adde01a85a45a429c823e592e000a6f209a126ebedb429c0e41fbcd4cf611ed26abec010e3336a7ba68edb81fd83b98c969cc73b1
+EBUILD capistrano-3.10.1.ebuild 1175 BLAKE2B 0d2b3411fb577ab260e2fbd7c8a69dba1f6314e21f254fb02b7119f640ad79fd1a3078aa88d855be050d89883f027a7306d05f6851a7c5ff7ccd54fed60a3a8c SHA512 4fd4323826ca08915b3443fe147c200d2ff81f16566afef94beced1fa02f4e45dad3c21ea254a5b490dac0b02339eb32291b0939ba8d58b923e57765d578afab
+EBUILD capistrano-3.10.2.ebuild 1175 BLAKE2B 0d2b3411fb577ab260e2fbd7c8a69dba1f6314e21f254fb02b7119f640ad79fd1a3078aa88d855be050d89883f027a7306d05f6851a7c5ff7ccd54fed60a3a8c SHA512 4fd4323826ca08915b3443fe147c200d2ff81f16566afef94beced1fa02f4e45dad3c21ea254a5b490dac0b02339eb32291b0939ba8d58b923e57765d578afab
+MISC metadata.xml 395 BLAKE2B de7df6f620f49f99e10fb18c145f58369dc5cbb85b70a2c10fa05c8bb12fd8700ee5fc57fe1c695fe8be2625f82d7b96e1b9bfb24af23eb7776231c763ac64c3 SHA512 c969db304610c45088a5efac1e694bc7ccfcf0360631fa43fe10f48ea045f6c400ec6cf3faa97e153b95133a1d1e1ebc9fca48c1d3ea1b63f73bb33d5546bc28
diff --git a/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild b/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild
new file mode 100644
index 000000000000..34e487855213
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-2.15.5-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.0.14:*
+ >=dev-ruby/net-sftp-2.0.2
+ >=dev-ruby/net-scp-1.0.2
+ >=dev-ruby/net-ssh-gateway-1.1.0:*
+ >=dev-ruby/highline-1.2.7"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha:0.14 )"
+
+RUBY_PATCHES=( ${P}-sudo-cleanup.patch )
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile test/utils.rb || die
+ sed -i -e '/pry/ s:^:#:' -e '4igem "mocha", "~>0.14.0"' test/utils.rb || die
+
+ # Avoid copy strategy tests since these fail in some cases due to
+ # complicated (aka unknown) interactions with other parts of the
+ # test suite.
+ rm test/deploy/strategy/copy_test.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper cap /usr/bin/cap-2 'gem "capistrano", "~>2.0"'
+}
diff --git a/dev-ruby/capistrano/capistrano-3.10.1.ebuild b/dev-ruby/capistrano/capistrano-3.10.1.ebuild
new file mode 100644
index 000000000000..4f29f3288d21
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-3.10.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/airbrussh-1.0.0
+ >=dev-ruby/sshkit-1.9:0
+ >=dev-ruby/rake-10.0.0
+ dev-ruby/i18n:*
+ !!<dev-ruby/capistrano-2.15.5-r2"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ # Avoid specs that depend on capistrano already being installed
+ rm -f spec/lib/capistrano/doctor/gems_doctor_spec.rb || die
+}
+
+pkg_postinst() {
+ einfo "Capistrano 3.1 has some breaking changes. Please check the CHANGELOG: http://goo.gl/SxB0lr"
+ einfo "If you're upgrading Capistrano from 2.x, we recommend to read the upgrade guide: http://goo.gl/4536kB"
+ einfo "The 'deploy:restart' hook for passenger applications is now in a separate gem called capistrano-passenger. Just add it to your Gemfile and require it in your Capfile."
+}
diff --git a/dev-ruby/capistrano/capistrano-3.10.2.ebuild b/dev-ruby/capistrano/capistrano-3.10.2.ebuild
new file mode 100644
index 000000000000..4f29f3288d21
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-3.10.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capistranorb.com/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/airbrussh-1.0.0
+ >=dev-ruby/sshkit-1.9:0
+ >=dev-ruby/rake-10.0.0
+ dev-ruby/i18n:*
+ !!<dev-ruby/capistrano-2.15.5-r2"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ # Avoid specs that depend on capistrano already being installed
+ rm -f spec/lib/capistrano/doctor/gems_doctor_spec.rb || die
+}
+
+pkg_postinst() {
+ einfo "Capistrano 3.1 has some breaking changes. Please check the CHANGELOG: http://goo.gl/SxB0lr"
+ einfo "If you're upgrading Capistrano from 2.x, we recommend to read the upgrade guide: http://goo.gl/4536kB"
+ einfo "The 'deploy:restart' hook for passenger applications is now in a separate gem called capistrano-passenger. Just add it to your Gemfile and require it in your Capfile."
+}
diff --git a/dev-ruby/capistrano/files/capistrano-2.15.5-sudo-cleanup.patch b/dev-ruby/capistrano/files/capistrano-2.15.5-sudo-cleanup.patch
new file mode 100644
index 000000000000..cbe68a476fd4
--- /dev/null
+++ b/dev-ruby/capistrano/files/capistrano-2.15.5-sudo-cleanup.patch
@@ -0,0 +1,12 @@
+diff -ur /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.15.5/lib/capistrano/recipes/deploy.rb ./lib/capistrano/recipes/deploy.rb
+--- ./lib/capistrano/recipes/deploy.rb 2014-08-13 15:11:31.423773610 +0200
++++ /usr/lib/ruby/gems/1.9.1/gems/capistrano-2.15.5/lib/capistrano/recipes/deploy.rb 2014-05-04 11:40:39.000000000 +0200
+@@ -462,7 +462,7 @@
+ DESC
+ task :cleanup, :except => { :no_release => true } do
+ count = fetch(:keep_releases, 5).to_i
+- try_sudo "ls -1dt #{releases_path}/* | tail -n +#{count + 1} | #{try_sudo} xargs rm -rf"
++ run "ls -1dt #{releases_path}/* | tail -n +#{count + 1} | #{try_sudo} xargs rm -rf"
+ end
+
+ desc <<-DESC
diff --git a/dev-ruby/capistrano/metadata.xml b/dev-ruby/capistrano/metadata.xml
new file mode 100644
index 000000000000..7ce59145bbd9
--- /dev/null
+++ b/dev-ruby/capistrano/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+<longdescription>
+Capistrano is a utility and framework for executing commands in parallel on
+multiple remote machines, via SSH.
+</longdescription>
+</pkgmetadata>