summaryrefslogtreecommitdiff
path: root/dev-ruby/bundler/bundler-1.15.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bundler/bundler-1.15.4.ebuild')
-rw-r--r--dev-ruby/bundler/bundler-1.15.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/bundler/bundler-1.15.4.ebuild b/dev-ruby/bundler/bundler-1.15.4.ebuild
new file mode 100644
index 000000000000..520639907a2c
--- /dev/null
+++ b/dev-ruby/bundler/bundler-1.15.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+# The specs require a number of gems to be installed in a temporary
+# directory, but this requires network access. They also don't work
+# when run with a path that contains "-".
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="https://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+doc test"
+
+ruby_add_rdepend virtual/rubygems
+
+ruby_add_bdepend "doc? ( app-text/ronn )"
+
+RDEPEND+=" dev-vcs/git"
+
+each_ruby_compile() {
+ if use doc ; then
+ ${RUBY} -S rake man:build || die
+ fi
+}