summaryrefslogtreecommitdiff
path: root/dev-ruby/binding_of_caller/binding_of_caller-1.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/binding_of_caller/binding_of_caller-1.0.1.ebuild')
-rw-r--r--dev-ruby/binding_of_caller/binding_of_caller-1.0.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/binding_of_caller/binding_of_caller-1.0.1.ebuild b/dev-ruby/binding_of_caller/binding_of_caller-1.0.1.ebuild
new file mode 100644
index 000000000000..90fe35a91cb9
--- /dev/null
+++ b/dev-ruby/binding_of_caller/binding_of_caller-1.0.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="binding_of_caller.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the binding of a method's caller"
+HOMEPAGE="https://github.com/banister/binding_of_caller"
+SRC_URI="https://github.com/banister/binding_of_caller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/debug_inspector-1.2.0"
+
+all_ruby_prepare() {
+ sed -i -e "s:_relative ': './:" -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+}