summaryrefslogtreecommitdiff
path: root/dev-ruby/bindex/bindex-0.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/bindex/bindex-0.8.1.ebuild')
-rw-r--r--dev-ruby/bindex/bindex-0.8.1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-ruby/bindex/bindex-0.8.1.ebuild b/dev-ruby/bindex/bindex-0.8.1.ebuild
deleted file mode 100644
index 01c48985a7ea..000000000000
--- a/dev-ruby/bindex/bindex-0.8.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Bindings for your Ruby exceptions"
-HOMEPAGE="https://github.com/gsamokovarov/bindex"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-all_ruby_prepare() {
- sed -e '/bundler/I s:^:#:' \
- -e '/when/ s/ruby/rubyx/' \
- -i Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/skiptrace extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/skiptrace
- cp ext/skiptrace/cruby.so lib/skiptrace/internal/ || die
-}