summaryrefslogtreecommitdiff
path: root/dev-ruby/ast/ast-2.4.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ast/ast-2.4.2.ebuild')
-rw-r--r--dev-ruby/ast/ast-2.4.2.ebuild33
1 files changed, 0 insertions, 33 deletions
diff --git a/dev-ruby/ast/ast-2.4.2.ebuild b/dev-ruby/ast/ast-2.4.2.ebuild
deleted file mode 100644
index 22d090d9c703..000000000000
--- a/dev-ruby/ast/ast-2.4.2.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby26 ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="ast.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A library for working with abstract syntax trees"
-HOMEPAGE="https://github.com/whitequark/ast"
-SRC_URI="https://github.com/whitequark/ast/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~sparc"
-IUSE=""
-
-ruby_add_bdepend "test? (
- dev-ruby/bacon )"
-
-all_ruby_prepare() {
- sed -i -e "/[Bb]undler/d" Rakefile || die
- sed -i -e "/git ls/d" ${PN}.gemspec || die
- sed -i -e "/simplecov/,+11d" -e "/colored_output/d" test/helper.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -S bacon -Itest -a || die
-}