summaryrefslogtreecommitdiff
path: root/dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild')
-rw-r--r--dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild b/dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild
new file mode 100644
index 000000000000..bd14dd1ef17d
--- /dev/null
+++ b/dev-ruby/asciidoctor/asciidoctor-1.5.5-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST="test features"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.adoc README.adoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for converting AsciiDoc into HTML 5, DocBook 4.5 and other formats"
+HOMEPAGE="https://github.com/asciidoctor/asciidoctor"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 x86"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-util/cucumber
+ dev-ruby/rspec-expectations:*
+ dev-ruby/asciimath
+ dev-ruby/coderay
+ dev-ruby/erubis
+ dev-ruby/haml
+ dev-ruby/nokogiri
+ dev-ruby/slim
+ dev-ruby/tilt )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/asciidoctor.1
+}