summaryrefslogtreecommitdiff
path: root/dev-ruby/ascii85/ascii85-1.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ascii85/ascii85-1.1.0.ebuild')
-rw-r--r--dev-ruby/ascii85/ascii85-1.1.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/ascii85/ascii85-1.1.0.ebuild b/dev-ruby/ascii85/ascii85-1.1.0.ebuild
new file mode 100644
index 000000000000..4bbddd140e29
--- /dev/null
+++ b/dev-ruby/ascii85/ascii85-1.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md History.txt"
+
+RUBY_FAKEGEM_NAME="Ascii85"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Methods for encoding/decoding Adobe's binary-to-text encoding of the same name"
+HOMEPAGE="https://github.com/datawraith/ascii85gem"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+}