summaryrefslogtreecommitdiff
path: root/dev-ruby/ansi/ansi-1.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/ansi/ansi-1.5.0.ebuild')
-rw-r--r--dev-ruby/ansi/ansi-1.5.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/ansi/ansi-1.5.0.ebuild b/dev-ruby/ansi/ansi-1.5.0.ebuild
new file mode 100644
index 000000000000..2b18435c2376
--- /dev/null
+++ b/dev-ruby/ansi/ansi-1.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="DEMO.md HISTORY.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The Ruby ANSI project is collection of ANSI escape codes for Ruby"
+HOMEPAGE="https://rubyworks.github.io/ansi/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# Tests cause circular dependencies with dev-ruby/qed & dev-ruby/rubytest
+RESTRICT="test"