summaryrefslogtreecommitdiff
path: root/dev-ruby/activestorage/activestorage-5.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/activestorage/activestorage-5.2.0.ebuild')
-rw-r--r--dev-ruby/activestorage/activestorage-5.2.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-ruby/activestorage/activestorage-5.2.0.ebuild b/dev-ruby/activestorage/activestorage-5.2.0.ebuild
index 7d7401cba939..0fc602e58822 100644
--- a/dev-ruby/activestorage/activestorage-5.2.0.ebuild
+++ b/dev-ruby/activestorage/activestorage-5.2.0.ebuild
@@ -21,11 +21,13 @@ SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz
LICENSE="MIT"
SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE=""
RUBY_S="rails-${PV}/${PN}"
+DEPEND+=" test? ( app-text/mupdf ) "
+
ruby_add_rdepend "
~dev-ruby/actionpack-${PV}:*
~dev-ruby/activerecord-${PV}:*
@@ -38,12 +40,14 @@ ruby_add_bdepend "
dev-ruby/test-unit:2
dev-ruby/mini_magick
dev-ruby/mocha
+ dev-ruby/rake
+ dev-ruby/sqlite3
)"
all_ruby_prepare() {
# Remove items from the common Gemfile that we don't need for this
# test run. This also requires handling some gemspecs.
- sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|aws-sdk-s3\|google-cloud-storage\|azure-storage\|blade\|bootsnap\|hiredis\|qunit-selenium\|chromedriver-helper\|redis\|rb-inotify\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|sass-rails\|rubocop\)/ s:^:#:" \
+ sed -i -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|sprockets-rails\|redcarpet\|bcrypt\|uglifier\|aws-sdk-s3\|google-cloud-storage\|azure-storage\|blade\|bootsnap\|hiredis\|qunit-selenium\|chromedriver-helper\|redis\|rb-inotify\|sprockets\|stackprof\|websocket-client-simple\|libxml-ruby\|sass-rails\|rubocop\|capybara\|rack-cache\|json\|dalli\|listen\|connection_pool\|puma\|mysql2\)/ s:^:#:" \
-e '/dalli/ s/2.7.7/2.7.9/' \
-e '/:job/,/end/ s:^:#:' \
-e '/:test/,/^end/ s:^:#:' \