summaryrefslogtreecommitdiff
path: root/dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild')
-rw-r--r--dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild b/dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild
index 469ece6f2567..48e5bf081edc 100644
--- a/dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild
+++ b/dev-ruby/actionpack-xml_parser/actionpack-xml_parser-2.0.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby22 ruby23 ruby24"
+USE_RUBY="ruby24 ruby25 ruby26"
RUBY_FAKEGEM_TASK_DOC=""
@@ -22,9 +22,12 @@ ruby_add_rdepend "=dev-ruby/actionpack-5*:* =dev-ruby/railties-5*:*"
all_ruby_prepare() {
sed -i -e "/bundler/d" Rakefile test/helper.rb || die
- sed -i -e '1igem "actionpack", "~>5.0"' test/helper.rb || die
+ sed -i -e '1igem "actionpack", "~>5.2"' test/helper.rb || die
+
+ # Skip test that is not compatible with Rails 5.2
+ sed -i -e '/occurring a parse error if parsing unsuccessful/askip "rails 5.2"' test/xml_params_parsing_test.rb || die
}
each_ruby_test() {
- ${RUBY} -Ilib:.:test -e "Dir['test/*_test.rb'].each{|f| require f}"
+ MT_NO_PLUGINS=true ${RUBY} -Ilib:.:test -e "Dir['test/*_test.rb'].each{|f| require f}" || die
}