summaryrefslogtreecommitdiff
path: root/dev-ros/visp_hand2eye_calibration
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/visp_hand2eye_calibration')
-rw-r--r--dev-ros/visp_hand2eye_calibration/Manifest4
-rw-r--r--dev-ros/visp_hand2eye_calibration/metadata.xml11
-rw-r--r--dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.10.0.ebuild31
-rw-r--r--dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild31
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-ros/visp_hand2eye_calibration/Manifest b/dev-ros/visp_hand2eye_calibration/Manifest
new file mode 100644
index 000000000000..b34f7c2ea8b3
--- /dev/null
+++ b/dev-ros/visp_hand2eye_calibration/Manifest
@@ -0,0 +1,4 @@
+DIST vision_visp-0.10.0.tar.gz 1015180 BLAKE2B bf0474d0633a6b704077e232d4676e6ebb9ec666b9b03792dbb929c6c6d1c52a941f7a4517f7bc6a7150882c16ba719eb3cf17c3fbdd13df109eab3a34afa259 SHA512 8e2652d6ca9c9535f1bebb628ec908f64c9fc89358bc92ed42ef12430b0b28c8ed3ed7935d2d3fe03c9761f9ac08e200eb59839ee2243df62d5934e8162cca9c
+EBUILD visp_hand2eye_calibration-0.10.0.ebuild 762 BLAKE2B 526819534d6867cb00cd6252ef696da6bc38405c1661900442b05baf28d8d044b149e650d30e92f214881f6e28bf340e787f174754b59a461a6cc923c88d7ba7 SHA512 d4ffd817f6bcb52b31c304a5c40eb303cd68c1ad294c37f47aa3df75d6306fdeef4e870147204a2fcdfb826622ba8f4600e0aa78e23d99eb971e4863fa5d6757
+EBUILD visp_hand2eye_calibration-9999.ebuild 762 BLAKE2B 526819534d6867cb00cd6252ef696da6bc38405c1661900442b05baf28d8d044b149e650d30e92f214881f6e28bf340e787f174754b59a461a6cc923c88d7ba7 SHA512 d4ffd817f6bcb52b31c304a5c40eb303cd68c1ad294c37f47aa3df75d6306fdeef4e870147204a2fcdfb826622ba8f4600e0aa78e23d99eb971e4863fa5d6757
+MISC metadata.xml 333 BLAKE2B 107f301bea0dd9adee5e472d36be074cc6a57d8a49fa14cb28b5aca166e99c73f3aaf19ce77acd1040bddcd86c3961f1411e994cd1ce9c0a636cff7d11e4ea66 SHA512 ddf6afe9a48cd4b3a1387aa6e7f0a46260ee2aaeb99d93e96aecac0ba5c36d59b578cc40c0337d40c5ecb9e485a3506138932897c0d9b5a8972d6ad479fa64a3
diff --git a/dev-ros/visp_hand2eye_calibration/metadata.xml b/dev-ros/visp_hand2eye_calibration/metadata.xml
new file mode 100644
index 000000000000..1b7d80220614
--- /dev/null
+++ b/dev-ros/visp_hand2eye_calibration/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lagadic/vision_visp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.10.0.ebuild b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.10.0.ebuild
new file mode 100644
index 000000000000..e85afb2fc607
--- /dev/null
+++ b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-0.10.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="kinetic-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Estimates the camera position with respect to its effector using the ViSP library"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/image_proc
+ dev-ros/roscpp
+ dev-ros/sensor_msgs
+ dev-ros/visp_bridge
+ dev-ros/visp_tracker
+ sci-libs/ViSP:=
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
+fi
diff --git a/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild
new file mode 100644
index 000000000000..e85afb2fc607
--- /dev/null
+++ b/dev-ros/visp_hand2eye_calibration/visp_hand2eye_calibration-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/lagadic/vision_visp"
+KEYWORDS="~amd64 ~arm"
+VER_PREFIX="kinetic-"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Estimates the camera position with respect to its effector using the ViSP library"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/image_proc
+ dev-ros/roscpp
+ dev-ros/sensor_msgs
+ dev-ros/visp_bridge
+ dev-ros/visp_tracker
+ sci-libs/ViSP:=
+"
+DEPEND="${RDEPEND}"
+if [ "${PV#9999}" = "${PV}" ] ; then
+ S="${WORKDIR}/vision_visp-kinetic-${PV}/${ROS_SUBDIR}"
+fi