summaryrefslogtreecommitdiff
path: root/dev-ros/turtle_actionlib
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/turtle_actionlib')
-rw-r--r--dev-ros/turtle_actionlib/Manifest6
-rw-r--r--dev-ros/turtle_actionlib/metadata.xml11
-rw-r--r--dev-ros/turtle_actionlib/turtle_actionlib-0.1.10.ebuild28
-rw-r--r--dev-ros/turtle_actionlib/turtle_actionlib-0.1.11.ebuild28
-rw-r--r--dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild28
5 files changed, 101 insertions, 0 deletions
diff --git a/dev-ros/turtle_actionlib/Manifest b/dev-ros/turtle_actionlib/Manifest
new file mode 100644
index 000000000000..23d37a11fda7
--- /dev/null
+++ b/dev-ros/turtle_actionlib/Manifest
@@ -0,0 +1,6 @@
+DIST common_tutorials-0.1.10.tar.gz 12511 BLAKE2B deeb06317c0f56f2496277f488592ba056b82440cb320fc9ea6bd3d2d6b8828301ce03c2f5db9ed1871b4f6a1caa8c874a510c912ab89ef1d05b01f364ee09be SHA512 92a1eb5865ec3b4acc9e04a507f050d9568e583ce6d0a29f3c6ab37f4c2feb5149f1ddd6269ce1a310251f7b4cbfe8a05c7e4c6bf4c3ca21c15d84f1c6f0422b
+DIST common_tutorials-0.1.11.tar.gz 12527 BLAKE2B 679cee86aad711677d1ed74320832c7ceb6d66adb34b835a80ad536be7bff517a78ca43e04372de23b491f8156ea3a4c268b4661d74fb1c04130e39033e1b961 SHA512 a42ab4b95eeaf9620ae0987f4e1cc530213b39455dea3ff8d944ac24ee7ed8e321ac8ed4f73b8e4d8d882248a850dface0169a5d521b02b226e6d0cb6016a33a
+EBUILD turtle_actionlib-0.1.10.ebuild 634 BLAKE2B 745ef90c77f08d117725b38f0773985a73d598a4a91f5babc665c37d1cf2c60f4322599ce04145bcb1cb8152b42be0c4dcdc42009aa35a7895037b21eab9ab6e SHA512 2a0ef4ee5450238045a2e5b35b65617b34f2e64cb9806ebf9deb875f34f168cea16a71021361a266293710c1621da2f7cf1afeebc111e9460809b63efd2d5324
+EBUILD turtle_actionlib-0.1.11.ebuild 634 BLAKE2B 86fd2f1a690b9eb1dea0cf798c3befb1609b67876e26673cc0f7cfa8415dc4c52a4d781a6879c0092b53c1f67d22b2abc79f82040cbd3756f3a9a3709efc98d0 SHA512 9415ee6698ea4f3b7d5c78f6fd606f1d1d22ce9ffa2df0d13bf015a7092847e91dbfe018c2aebcf7cc09f8c1d308b45278945ebc753f2d155aaa629fe6031de9
+EBUILD turtle_actionlib-9999.ebuild 634 BLAKE2B 745ef90c77f08d117725b38f0773985a73d598a4a91f5babc665c37d1cf2c60f4322599ce04145bcb1cb8152b42be0c4dcdc42009aa35a7895037b21eab9ab6e SHA512 2a0ef4ee5450238045a2e5b35b65617b34f2e64cb9806ebf9deb875f34f168cea16a71021361a266293710c1621da2f7cf1afeebc111e9460809b63efd2d5324
+MISC metadata.xml 334 BLAKE2B 9448c76327ed1df85e94f230f66b62356f9f3f6e0ae2853cba879c3357bf19ba534098914207e4bca6e21b3a1e33a5a911084a5f83b9d9b1bdba8282bf70b6e5 SHA512 dcec72972fcaf9c06c0fcc8ed3825875667e3391de433ace73961159cede1a33c40f7dfca78ca22e018e730024af73562786f90fcc1f2ccf39ab11106f37d038
diff --git a/dev-ros/turtle_actionlib/metadata.xml b/dev-ros/turtle_actionlib/metadata.xml
new file mode 100644
index 000000000000..ac14dc3adf6f
--- /dev/null
+++ b/dev-ros/turtle_actionlib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/common_tutorials</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/turtle_actionlib/turtle_actionlib-0.1.10.ebuild b/dev-ros/turtle_actionlib/turtle_actionlib-0.1.10.ebuild
new file mode 100644
index 000000000000..14da5732c951
--- /dev/null
+++ b/dev-ros/turtle_actionlib/turtle_actionlib-0.1.10.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/common_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates how to write an action server and client with the turtlesim"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib
+ dev-ros/actionlib_msgs
+ dev-ros/angles
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/turtlesim
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/turtle_actionlib/turtle_actionlib-0.1.11.ebuild b/dev-ros/turtle_actionlib/turtle_actionlib-0.1.11.ebuild
new file mode 100644
index 000000000000..24600b2d603f
--- /dev/null
+++ b/dev-ros/turtle_actionlib/turtle_actionlib-0.1.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/common_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates how to write an action server and client with the turtlesim"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib
+ dev-ros/actionlib_msgs
+ dev-ros/angles
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/turtlesim
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild b/dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild
new file mode 100644
index 000000000000..14da5732c951
--- /dev/null
+++ b/dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/common_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates how to write an action server and client with the turtlesim"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib
+ dev-ros/actionlib_msgs
+ dev-ros/angles
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/turtlesim
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"