summaryrefslogtreecommitdiff
path: root/dev-ros/timestamp_tools
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/timestamp_tools')
-rw-r--r--dev-ros/timestamp_tools/Manifest5
-rw-r--r--dev-ros/timestamp_tools/files/tests.patch14
-rw-r--r--dev-ros/timestamp_tools/metadata.xml11
-rw-r--r--dev-ros/timestamp_tools/timestamp_tools-1.6.8.ebuild22
-rw-r--r--dev-ros/timestamp_tools/timestamp_tools-9999.ebuild22
5 files changed, 74 insertions, 0 deletions
diff --git a/dev-ros/timestamp_tools/Manifest b/dev-ros/timestamp_tools/Manifest
new file mode 100644
index 000000000000..1fa0090bfbf3
--- /dev/null
+++ b/dev-ros/timestamp_tools/Manifest
@@ -0,0 +1,5 @@
+AUX tests.patch 652 BLAKE2B 5542e9c18f33575defc466ff28bce65742f09c37d92f1d94ff1143007e45c80bdc9dd453f15d8688bbb0028ead676e619923226cad7342bd70483bd51b4e9e18 SHA512 c2cb51521d82a93857bf67ceb0090e78c1973eaf17a0ed8376b844d1c45b736b9ecab7214636eeeef3af7ff9c2e58030d37dd707a3be0c7af8f81e26dba345f0
+DIST driver_common-1.6.8.tar.gz 15055 BLAKE2B 2d9a4c23d65b8e2f60343f5e3b454e1cc41334d34e0246891b533f216acb743df628d95dd2c0087b06284a85e0ea872baad495a7ed7b59c03e8f8ff32eba4ed8 SHA512 b698143d08785088ac13e62f5b96676bd590a84e4ffb147fa3698be6a8ded510f648d043ecdc1d31ba7b95fb3041d06ee1a39b224c359b8612adebdba259d188
+EBUILD timestamp_tools-1.6.8.ebuild 451 BLAKE2B 3f883ffad47f4d8ac27276c9c7de5d6cc33d5409f6d3dfd16ec10555c11ee9ec9f47fb70ed4b0990642c4deddafe90ebf493ff589f5ff105d6fdec5961387953 SHA512 2ee923cb3696eb675f1949a553e8cff4fb6b49f33907874c682825877380a8773196d3be436df3c3d09a74905cebd6633173e636661e52ad99dcae88d4021348
+EBUILD timestamp_tools-9999.ebuild 451 BLAKE2B 3f883ffad47f4d8ac27276c9c7de5d6cc33d5409f6d3dfd16ec10555c11ee9ec9f47fb70ed4b0990642c4deddafe90ebf493ff589f5ff105d6fdec5961387953 SHA512 2ee923cb3696eb675f1949a553e8cff4fb6b49f33907874c682825877380a8773196d3be436df3c3d09a74905cebd6633173e636661e52ad99dcae88d4021348
+MISC metadata.xml 339 BLAKE2B 71ed9f79df6d8528f3d967c077f1d01e0290573400356e3749bd24254281651f09507894d2ca4029b8b8a77b51d31d080d9560d9995d3d9fde848f0d71ec083d SHA512 e24ff4ef526475ad5bff434350abb00afccb4c101ab624ee056c1502719d15ec4889eff9170c534af62ba8719bd5fe4f3cf206353244f56e486a29afea53ee7b
diff --git a/dev-ros/timestamp_tools/files/tests.patch b/dev-ros/timestamp_tools/files/tests.patch
new file mode 100644
index 000000000000..c73d09a1b1ac
--- /dev/null
+++ b/dev-ros/timestamp_tools/files/tests.patch
@@ -0,0 +1,14 @@
+Index: driver_common-1.6.8/timestamp_tools/CMakeLists.txt
+===================================================================
+--- driver_common-1.6.8.orig/timestamp_tools/CMakeLists.txt
++++ driver_common-1.6.8/timestamp_tools/CMakeLists.txt
+@@ -17,5 +17,7 @@ install(DIRECTORY include/${PROJECT_NAME
+ DESTINATION ${CATKIN_PACKAGE_INCLUDE_DESTINATION}
+ FILES_MATCHING PATTERN "*.h")
+
++if(CATKIN_ENABLE_TESTING)
+ catkin_add_gtest(test_trigger_matcher test/test_trigger_matcher.cpp)
+-target_link_libraries(test_trigger_matcher ${catkin_LIBRARIES})
+\ No newline at end of file
++target_link_libraries(test_trigger_matcher ${catkin_LIBRARIES})
++endif()
diff --git a/dev-ros/timestamp_tools/metadata.xml b/dev-ros/timestamp_tools/metadata.xml
new file mode 100644
index 000000000000..e4029ce25b8b
--- /dev/null
+++ b/dev-ros/timestamp_tools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-drivers/driver_common</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/timestamp_tools/timestamp_tools-1.6.8.ebuild b/dev-ros/timestamp_tools/timestamp_tools-1.6.8.ebuild
new file mode 100644
index 000000000000..1c7b8786e13d
--- /dev/null
+++ b/dev-ros/timestamp_tools/timestamp_tools-1.6.8.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/driver_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Classes to help timestamp hardware events"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslib
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/tests.patch" )
diff --git a/dev-ros/timestamp_tools/timestamp_tools-9999.ebuild b/dev-ros/timestamp_tools/timestamp_tools-9999.ebuild
new file mode 100644
index 000000000000..1c7b8786e13d
--- /dev/null
+++ b/dev-ros/timestamp_tools/timestamp_tools-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/driver_common"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Classes to help timestamp hardware events"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslib
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/tests.patch" )