summaryrefslogtreecommitdiff
path: root/dev-ros/tf2_tools/tf2_tools-0.7.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/tf2_tools/tf2_tools-0.7.5.ebuild')
-rw-r--r--dev-ros/tf2_tools/tf2_tools-0.7.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/tf2_tools/tf2_tools-0.7.5.ebuild b/dev-ros/tf2_tools/tf2_tools-0.7.5.ebuild
new file mode 100644
index 000000000000..96f06f51e767
--- /dev/null
+++ b/dev-ros/tf2_tools/tf2_tools-0.7.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros/geometry2"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for 2nd gen Transform library"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_py[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyyaml[\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}"