summaryrefslogtreecommitdiff
path: root/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-9999.ebuild')
-rw-r--r--dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-9999.ebuild30
1 files changed, 21 insertions, 9 deletions
diff --git a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-9999.ebuild b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-9999.ebuild
index 9d28f70aecb0..b6d6fb7ff23f 100644
--- a/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-9999.ebuild
+++ b/dev-ros/tf2_sensor_msgs/tf2_sensor_msgs-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/geometry2"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -15,12 +14,25 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/tf2_ros[${PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_SINGLE_USEDEP}]
dev-ros/tf2
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP},${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- test? ( dev-ros/rostest[${PYTHON_USEDEP}] )
- dev-ros/cmake_modules"
+ test? (
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/gtest
+ )
+ dev-ros/cmake_modules
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/eigen:3
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}