summaryrefslogtreecommitdiff
path: root/dev-ros/test_tf2/test_tf2-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_tf2/test_tf2-9999.ebuild')
-rw-r--r--dev-ros/test_tf2/test_tf2-9999.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/dev-ros/test_tf2/test_tf2-9999.ebuild b/dev-ros/test_tf2/test_tf2-9999.ebuild
index 4378c07e804e..24179b340482 100644
--- a/dev-ros/test_tf2/test_tf2-9999.ebuild
+++ b/dev-ros/test_tf2/test_tf2-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/geometry2"
KEYWORDS="~amd64"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
@@ -18,17 +17,19 @@ RDEPEND=""
DEPEND="
dev-ros/rosconsole
dev-ros/roscpp
- dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
dev-ros/tf
dev-ros/tf2
dev-ros/tf2_bullet
- dev-ros/tf2_ros[${PYTHON_USEDEP}]
- dev-ros/tf2_geometry_msgs[${PYTHON_USEDEP}]
- dev-ros/tf2_kdl[${PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_geometry_msgs[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/tf2_kdl[${PYTHON_SINGLE_USEDEP}]
dev-ros/tf2_msgs
+ dev-ros/rosbash
sci-libs/orocos_kdl
- dev-python/python_orocos_kdl[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
dev-libs/boost:=[threads]
- dev-cpp/gtest"
+ dev-cpp/gtest
+"
mycatkincmakeargs=( "-DCATKIN_ENABLE_TESTING=ON" )