summaryrefslogtreecommitdiff
path: root/dev-ros/test_rosparam/test_rosparam-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_rosparam/test_rosparam-9999.ebuild')
-rw-r--r--dev-ros/test_rosparam/test_rosparam-9999.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-ros/test_rosparam/test_rosparam-9999.ebuild b/dev-ros/test_rosparam/test_rosparam-9999.ebuild
index 3a0084ca2436..712bc9fd620e 100644
--- a/dev-ros/test_rosparam/test_rosparam-9999.ebuild
+++ b/dev-ros/test_rosparam/test_rosparam-9999.ebuild
@@ -1,15 +1,13 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/ros_comm"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=test/${PN}
CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
-
inherit ros-catkin
DESCRIPTION="Unit tests for rosparam"
@@ -19,8 +17,13 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
- dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-ros/rosparam[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ dev-ros/rosparam[${PYTHON_SINGLE_USEDEP}]
)"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}