summaryrefslogtreecommitdiff
path: root/dev-ros/test_roscpp/test_roscpp-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_roscpp/test_roscpp-9999.ebuild')
-rw-r--r--dev-ros/test_roscpp/test_roscpp-9999.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/dev-ros/test_roscpp/test_roscpp-9999.ebuild b/dev-ros/test_roscpp/test_roscpp-9999.ebuild
index 13637bb57f1f..39bfc4bf09a4 100644
--- a/dev-ros/test_roscpp/test_roscpp-9999.ebuild
+++ b/dev-ros/test_roscpp/test_roscpp-9999.ebuild
@@ -1,13 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/ros_comm"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=test/${PN}
CATKIN_HAS_MESSAGES=yes
-PYTHON_COMPAT=( python2_7 )
CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
inherit ros-catkin
@@ -20,8 +19,8 @@ IUSE=""
RDEPEND=""
DEPEND="${RDEPEND}
dev-ros/roscpp
- dev-ros/rostest[${PYTHON_USEDEP}]
- dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-libs/boost:=[threads]
test? (
@@ -29,3 +28,9 @@ DEPEND="${RDEPEND}
)
"
REQUIRED_USE="test? ( ros_messages_cxx )"
+PATCHES=( "${FILESDIR}/tests.patch" )
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}