summaryrefslogtreecommitdiff
path: root/dev-ros/test_nodelet/files/gcc6.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_nodelet/files/gcc6.patch')
-rw-r--r--dev-ros/test_nodelet/files/gcc6.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-ros/test_nodelet/files/gcc6.patch b/dev-ros/test_nodelet/files/gcc6.patch
new file mode 100644
index 000000000000..102fe01879d6
--- /dev/null
+++ b/dev-ros/test_nodelet/files/gcc6.patch
@@ -0,0 +1,13 @@
+Index: test_nodelet/CMakeLists.txt
+===================================================================
+--- test_nodelet.orig/CMakeLists.txt
++++ test_nodelet/CMakeLists.txt
+@@ -8,7 +8,7 @@ catkin_package()
+ if(CATKIN_ENABLE_TESTING)
+ find_package(Boost REQUIRED thread)
+ find_package(catkin REQUIRED nodelet pluginlib rostest)
+- include_directories(SYSTEM ${BOOST_INCLUDE_DIRS}
++ include_directories(${BOOST_INCLUDE_DIRS}
+ ${catkin_INCLUDE_DIRS}
+ )
+