summaryrefslogtreecommitdiff
path: root/dev-ros/test_diagnostic_aggregator/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/test_diagnostic_aggregator/files')
-rw-r--r--dev-ros/test_diagnostic_aggregator/files/gcc6.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/dev-ros/test_diagnostic_aggregator/files/gcc6.patch b/dev-ros/test_diagnostic_aggregator/files/gcc6.patch
new file mode 100644
index 000000000000..2819decf3a76
--- /dev/null
+++ b/dev-ros/test_diagnostic_aggregator/files/gcc6.patch
@@ -0,0 +1,13 @@
+Index: test_diagnostic_aggregator/CMakeLists.txt
+===================================================================
+--- test_diagnostic_aggregator.orig/CMakeLists.txt
++++ test_diagnostic_aggregator/CMakeLists.txt
+@@ -9,7 +9,7 @@ catkin_package(DEPENDS diagnostic_aggreg
+ LIBRARIES ${PROJECT_NAME}
+ )
+
+-include_directories(SYSTEM ${catkin_INCLUDE_DIRS})
++include_directories(${catkin_INCLUDE_DIRS})
+ include_directories(include)
+
+ add_library(test_diagnostic_aggregator