summaryrefslogtreecommitdiff
path: root/dev-ros/stage_ros/stage_ros-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/stage_ros/stage_ros-1.8.0.ebuild')
-rw-r--r--dev-ros/stage_ros/stage_ros-1.8.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/stage_ros/stage_ros-1.8.0.ebuild b/dev-ros/stage_ros/stage_ros-1.8.0.ebuild
new file mode 100644
index 000000000000..3cdc7cdc4d1c
--- /dev/null
+++ b/dev-ros/stage_ros/stage_ros-1.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-simulation/stage_ros"
+KEYWORDS="~amd64"
+
+inherit ros-catkin
+
+DESCRIPTION="ROS specific hooks and tools for the Stage simulator"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/geometry_msgs
+ dev-ros/nav_msgs
+ dev-ros/roscpp
+ dev-ros/rostest
+ dev-ros/sensor_msgs
+ dev-ros/std_msgs
+ dev-ros/tf
+ x11-libs/fltk
+ >=sci-electronics/Stage-4.3:=
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest )
+ virtual/pkgconfig"