summaryrefslogtreecommitdiff
path: root/dev-ros/smach_msgs
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/smach_msgs')
-rw-r--r--dev-ros/smach_msgs/Manifest4
-rw-r--r--dev-ros/smach_msgs/metadata.xml11
-rw-r--r--dev-ros/smach_msgs/smach_msgs-2.0.1.ebuild21
-rw-r--r--dev-ros/smach_msgs/smach_msgs-9999.ebuild21
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-ros/smach_msgs/Manifest b/dev-ros/smach_msgs/Manifest
new file mode 100644
index 000000000000..eda4f81c8cad
--- /dev/null
+++ b/dev-ros/smach_msgs/Manifest
@@ -0,0 +1,4 @@
+DIST executive_smach-2.0.1.tar.gz 42032 BLAKE2B 9271515a67436cd4873d4df5d1abae586af9ae856f9c90904732382e4824bd0bb23c820cd761017532604cde4c7c07ed4a98465b3267319dbc00b61b2d028dea SHA512 88be9ad6a0ec1e82e1592d26621fbbfe24e45640266f369cd03f192649bfd865e5a4ea576cf665161c0f89805e67b38b8b64b62a054ca1e217b99d8284f3b32a
+EBUILD smach_msgs-2.0.1.ebuild 506 BLAKE2B a93afa5affc635f02e44936bbe492f26a2ff58eb321d903ab86f97b93d2425440d3b68f397e39b685245d9ee7f96a06a8a33013ed57728e0e638230a02a223e9 SHA512 adc687d877cc1e7e8550b7912ca0d3f88b6861696e05a41db8be3e7c08ec2ee4fffd1d1169a1f00a865bdd88462a917d35b7a12adbd44bca253e83ff7e9dbd31
+EBUILD smach_msgs-9999.ebuild 506 BLAKE2B a93afa5affc635f02e44936bbe492f26a2ff58eb321d903ab86f97b93d2425440d3b68f397e39b685245d9ee7f96a06a8a33013ed57728e0e638230a02a223e9 SHA512 adc687d877cc1e7e8550b7912ca0d3f88b6861696e05a41db8be3e7c08ec2ee4fffd1d1169a1f00a865bdd88462a917d35b7a12adbd44bca253e83ff7e9dbd31
+MISC metadata.xml 333 BLAKE2B 9464368a741c4058fe2563c0a8a575e29bf8a74c43430a6c6f7be286419f675a560290c95d2afdf6e942843e233680e86886237a43ebe8d36136ebd36b4feb04 SHA512 c5e649958133658717bd4d1723953187a4c9626c7a1143fa784bc10ef533165bcb386248a42e20e9c1f7de4147e34c5a09f1009c5c65a78e2ed8fa0ccfc56165
diff --git a/dev-ros/smach_msgs/metadata.xml b/dev-ros/smach_msgs/metadata.xml
new file mode 100644
index 000000000000..d2fce8b37504
--- /dev/null
+++ b/dev-ros/smach_msgs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/executive_smach</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/smach_msgs/smach_msgs-2.0.1.ebuild b/dev-ros/smach_msgs/smach_msgs-2.0.1.ebuild
new file mode 100644
index 000000000000..5bacb8924912
--- /dev/null
+++ b/dev-ros/smach_msgs/smach_msgs-2.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Set of messages that are used by the introspection interfaces for smach"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/smach_msgs/smach_msgs-9999.ebuild b/dev-ros/smach_msgs/smach_msgs-9999.ebuild
new file mode 100644
index 000000000000..5bacb8924912
--- /dev/null
+++ b/dev-ros/smach_msgs/smach_msgs-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/executive_smach"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Set of messages that are used by the introspection interfaces for smach"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"