summaryrefslogtreecommitdiff
path: root/dev-ros/shape_tools
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/shape_tools')
-rw-r--r--dev-ros/shape_tools/Manifest4
-rw-r--r--dev-ros/shape_tools/metadata.xml11
-rw-r--r--dev-ros/shape_tools/shape_tools-0.2.1.ebuild29
-rw-r--r--dev-ros/shape_tools/shape_tools-9999.ebuild29
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-ros/shape_tools/Manifest b/dev-ros/shape_tools/Manifest
new file mode 100644
index 000000000000..ae817a7815d3
--- /dev/null
+++ b/dev-ros/shape_tools/Manifest
@@ -0,0 +1,4 @@
+DIST shape_tools-0.2.1.tar.gz 3684 BLAKE2B bdc92056d3c92595243cd33c49c846fc91eb43576be2f4fac190eb09fa19695e7976496c3d4c6f036197666441cce6f92351648aa5a89a98377fa44d9d2d5cc8 SHA512 4d6da49528518776cb51ace908f0f0326b31b2928f0cb8ae0b12bcb0c1fdac99cbcd71f6bd3324d6aecc38a68a10012535b914a2349925eab1487eed8e1bede3
+EBUILD shape_tools-0.2.1.ebuild 637 BLAKE2B d3cfa9e3323105cc317349dd6749f4d0c20d8526edb5b99af81fe146475627fb90bbba8c5efbcbd95281686ec2e9f615e1b1492860799efd6f6f409513769307 SHA512 fb9b123810ef682917c6a148da59da3cbd85b82fee188bc89c23500a184b1ac2b98e81017abb067c960a028aee5d8d645c56d428f7260eb5150144c7c79f8c27
+EBUILD shape_tools-9999.ebuild 637 BLAKE2B d3cfa9e3323105cc317349dd6749f4d0c20d8526edb5b99af81fe146475627fb90bbba8c5efbcbd95281686ec2e9f615e1b1492860799efd6f6f409513769307 SHA512 fb9b123810ef682917c6a148da59da3cbd85b82fee188bc89c23500a184b1ac2b98e81017abb067c960a028aee5d8d645c56d428f7260eb5150144c7c79f8c27
+MISC metadata.xml 338 BLAKE2B af43f88379647e32b43627f2eee8d72a9bc3d42e4f1d73becd4a11c3921125486adf8f1cc61f247e9ffd96399991a51e1d32d67c313cb0c4ab6f9cdfacfa6e90 SHA512 cca0c8e2c77b741038575027d78d2520671d9ae820f74e69ef5913f7f7e12402e6643db4969c51bb932fb92e71a8cc19a0aab1c7719eb46b2eb966afd3e21651
diff --git a/dev-ros/shape_tools/metadata.xml b/dev-ros/shape_tools/metadata.xml
new file mode 100644
index 000000000000..fe1e16a33855
--- /dev/null
+++ b/dev-ros/shape_tools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-planning/shape_tools</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/shape_tools/shape_tools-0.2.1.ebuild b/dev-ros/shape_tools/shape_tools-0.2.1.ebuild
new file mode 100644
index 000000000000..be5d89f8bd96
--- /dev/null
+++ b/dev-ros/shape_tools/shape_tools-0.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-planning/shape_tools"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for operating on shape messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/shape_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
+ -i CMakeLists.txt \
+ || die
+}
diff --git a/dev-ros/shape_tools/shape_tools-9999.ebuild b/dev-ros/shape_tools/shape_tools-9999.ebuild
new file mode 100644
index 000000000000..be5d89f8bd96
--- /dev/null
+++ b/dev-ros/shape_tools/shape_tools-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-planning/shape_tools"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for operating on shape messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/shape_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
+ -i CMakeLists.txt \
+ || die
+}