summaryrefslogtreecommitdiff
path: root/dev-ros/shape_tools/shape_tools-0.2.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/shape_tools/shape_tools-0.2.1.ebuild')
-rw-r--r--dev-ros/shape_tools/shape_tools-0.2.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/shape_tools/shape_tools-0.2.1.ebuild b/dev-ros/shape_tools/shape_tools-0.2.1.ebuild
new file mode 100644
index 000000000000..be5d89f8bd96
--- /dev/null
+++ b/dev-ros/shape_tools/shape_tools-0.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-planning/shape_tools"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for operating on shape messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/shape_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
+ -i CMakeLists.txt \
+ || die
+}