summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_py_console
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rqt_py_console')
-rw-r--r--dev-ros/rqt_py_console/Manifest6
-rw-r--r--dev-ros/rqt_py_console/metadata.xml11
-rw-r--r--dev-ros/rqt_py_console/rqt_py_console-0.4.7.ebuild26
-rw-r--r--dev-ros/rqt_py_console/rqt_py_console-0.4.8.ebuild25
-rw-r--r--dev-ros/rqt_py_console/rqt_py_console-9999.ebuild25
5 files changed, 93 insertions, 0 deletions
diff --git a/dev-ros/rqt_py_console/Manifest b/dev-ros/rqt_py_console/Manifest
new file mode 100644
index 000000000000..eaa669b36eb6
--- /dev/null
+++ b/dev-ros/rqt_py_console/Manifest
@@ -0,0 +1,6 @@
+DIST rqt_common_plugins-0.4.7.tar.gz 246977 BLAKE2B 5efebfa64dcc587822e558b5527a2ef2e33adc8adcb45800876e278be5ccdacbaef93b0f9dfbb7b98972fd5cffb4fcddee80e9522a4135a736d744765c2490ed SHA512 eb10a7c03bb079d939a9705a08e9194c83e020235a13ed2d4ff8e9c3c73e5abbd0a9bd7c00587135767497b155bb9516d7b4c2240fbe2118d7b0668d6ee32ab7
+DIST rqt_py_console-0.4.8.tar.gz 5370 BLAKE2B 8538fed59cbf23454ba2aefe0e0293c39023b312dd1d42d86c3e83bb8f63110e95a596cf1e7fc162d6b9feed9fa360f628e5a60fd7bcb09d88a43f915c7c25e6 SHA512 8b041648778a7bfb6407d7cc6600a94013ebaf87b072688de308564f1a11f7fcf93e1c0f3b9f67f1d4eef981a455d5fb4e0a694852a914335e640ba421835ab4
+EBUILD rqt_py_console-0.4.7.ebuild 628 BLAKE2B 82d486f806ebb28816de20b66715cf5e1ee75f0f13a254138d99ad7492c4fbf23ca00f3eefb7d993b2b3bb5fcb56a6164d70257db5027818811154c59998b269 SHA512 0f33f3052402c40b74fbd4a496fc4825fb7d45500e34c9cde4f1cd561389c5597b508faea93edc70b103b05ca4075694fabaf6f0e3b0a0b94fa82e0512ae834b
+EBUILD rqt_py_console-0.4.8.ebuild 607 BLAKE2B dad2f4fd3a1a34c946c258910bffdf4b07f352cd33fdc75755f222178ca321ab590fe3e5b4b65f8a5f67d4ba38ffb9db825950a20c4f4f4c754de674aa674bbc SHA512 ce7ab977fd54f1795c238a4918abc21c4635ff9c7270384bd1cf57589e1e207210bbe55ca31096dab509960218da1f7d947f29024ecfa3495bc84af259ec7254
+EBUILD rqt_py_console-9999.ebuild 607 BLAKE2B dad2f4fd3a1a34c946c258910bffdf4b07f352cd33fdc75755f222178ca321ab590fe3e5b4b65f8a5f67d4ba38ffb9db825950a20c4f4f4c754de674aa674bbc SHA512 ce7ab977fd54f1795c238a4918abc21c4635ff9c7270384bd1cf57589e1e207210bbe55ca31096dab509960218da1f7d947f29024ecfa3495bc84af259ec7254
+MISC metadata.xml 346 BLAKE2B b161c9a69ca70a509d52e7944fd08411f14a1cd414e7e7b2f8c33e73a32a60c6256251e6f3f7400e450ed454f9f4c36e9f189d81fae535c106df178f7bbfb8ea SHA512 a49aa6af8d730d2eb71df70b58570704a8f9b0b800c44b02e695732b2e318818c073973664882986b23b743b7fe039e9dd30d3b43e918b7ba4732114c69c4bfa
diff --git a/dev-ros/rqt_py_console/metadata.xml b/dev-ros/rqt_py_console/metadata.xml
new file mode 100644
index 000000000000..1bdbc341eee0
--- /dev/null
+++ b/dev-ros/rqt_py_console/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-visualization/rqt_py_console</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rqt_py_console/rqt_py_console-0.4.7.ebuild b/dev-ros/rqt_py_console/rqt_py_console-0.4.7.ebuild
new file mode 100644
index 000000000000..3b828779aa24
--- /dev/null
+++ b/dev-ros/rqt_py_console/rqt_py_console-0.4.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python GUI plugin providing an interactive Python console"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_py_console/rqt_py_console-0.4.8.ebuild b/dev-ros/rqt_py_console/rqt_py_console-0.4.8.ebuild
new file mode 100644
index 000000000000..aa8cb2ad8c01
--- /dev/null
+++ b/dev-ros/rqt_py_console/rqt_py_console-0.4.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_py_console"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Python GUI plugin providing an interactive Python console"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_py_console/rqt_py_console-9999.ebuild b/dev-ros/rqt_py_console/rqt_py_console-9999.ebuild
new file mode 100644
index 000000000000..aa8cb2ad8c01
--- /dev/null
+++ b/dev-ros/rqt_py_console/rqt_py_console-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_py_console"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Python GUI plugin providing an interactive Python console"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"