summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_gui/rqt_gui-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rqt_gui/rqt_gui-9999.ebuild')
-rw-r--r--dev-ros/rqt_gui/rqt_gui-9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rqt_gui/rqt_gui-9999.ebuild b/dev-ros/rqt_gui/rqt_gui-9999.ebuild
new file mode 100644
index 000000000000..2f20b99ad0df
--- /dev/null
+++ b/dev-ros/rqt_gui/rqt_gui-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Main to start an instance of the ROS integrated graphical user interface provided by qt_gui"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ dev-libs/boost:="
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/gentoo.patch" )