summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_action
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rqt_action')
-rw-r--r--dev-ros/rqt_action/Manifest4
-rw-r--r--dev-ros/rqt_action/metadata.xml11
-rw-r--r--dev-ros/rqt_action/rqt_action-0.4.9.ebuild22
-rw-r--r--dev-ros/rqt_action/rqt_action-9999.ebuild22
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-ros/rqt_action/Manifest b/dev-ros/rqt_action/Manifest
new file mode 100644
index 000000000000..ccb872bee027
--- /dev/null
+++ b/dev-ros/rqt_action/Manifest
@@ -0,0 +1,4 @@
+DIST rqt_action-0.4.9.tar.gz 3288 BLAKE2B dab54459bae9975007c50e947d4e8ae6783ce653edc5132636d8a8edc02f55d832ad33910f7daec1c6ff139a4313b96dec64221ef296d6834dbbbdd43fa9cc66 SHA512 e412fe23bca87f2fc55a858ddc153ecfd6fcf7bdc60334d09285e3d44ab6d2cc52680f29d3bfd4fe9ad5bc334c595b311fcea5e835223dd61c19fd0de0489afc
+EBUILD rqt_action-0.4.9.ebuild 492 BLAKE2B 27271157608e13dbf6fe4582712a99b50c5c2c62c8ece6922b270564f761e0d9ac1b5a5a41762188be597cdb6781ac5596fc405a7a2b11d004881cacb2e13091 SHA512 89cda35a955c3fef8184abe5a9e57d187c531d385ee538812e6bf165d174dc95406bef6a6fc75c12f3fc6c6528544c35aa4f37e9681f11a6e74be8b4d073bab3
+EBUILD rqt_action-9999.ebuild 492 BLAKE2B 27271157608e13dbf6fe4582712a99b50c5c2c62c8ece6922b270564f761e0d9ac1b5a5a41762188be597cdb6781ac5596fc405a7a2b11d004881cacb2e13091 SHA512 89cda35a955c3fef8184abe5a9e57d187c531d385ee538812e6bf165d174dc95406bef6a6fc75c12f3fc6c6528544c35aa4f37e9681f11a6e74be8b4d073bab3
+MISC metadata.xml 342 BLAKE2B 620942e8e6c98f9cd2873d37c5983abad214b94afd52b4de803491e4d49bf777ed5b99ccad97f4cc11481022e276f733197ca995b6c8aea024b88fe9026be984 SHA512 d68ea776973eee1600ca75e3cec47e4db57d8f14f0b2ac796276d48763f71c513ac1deebfbe6e76261fd5af8f394981c05dd9dcf3b47c7b0029a46443cf10d1c
diff --git a/dev-ros/rqt_action/metadata.xml b/dev-ros/rqt_action/metadata.xml
new file mode 100644
index 000000000000..e5c138054234
--- /dev/null
+++ b/dev-ros/rqt_action/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-visualization/rqt_action</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rqt_action/rqt_action-0.4.9.ebuild b/dev-ros/rqt_action/rqt_action-0.4.9.ebuild
new file mode 100644
index 000000000000..d368b9658f68
--- /dev/null
+++ b/dev-ros/rqt_action/rqt_action-0.4.9.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_action"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Introspect all available ROS action (from actionlib) types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_msg[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_action/rqt_action-9999.ebuild b/dev-ros/rqt_action/rqt_action-9999.ebuild
new file mode 100644
index 000000000000..d368b9658f68
--- /dev/null
+++ b/dev-ros/rqt_action/rqt_action-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_action"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Introspect all available ROS action (from actionlib) types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_msg[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"