summaryrefslogtreecommitdiff
path: root/dev-ros/rostest/rostest-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rostest/rostest-9999.ebuild')
-rw-r--r--dev-ros/rostest/rostest-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-ros/rostest/rostest-9999.ebuild b/dev-ros/rostest/rostest-9999.ebuild
index c8b1067e86a3..37af233ee567 100644
--- a/dev-ros/rostest/rostest-9999.ebuild
+++ b/dev-ros/rostest/rostest-9999.ebuild
@@ -1,33 +1,33 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/ros_comm"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=tools/${PN}
-PYTHON_COMPAT=( python{2_7,3_6} pypy3 )
inherit ros-catkin
-DESCRIPTION="Integration test suite based on roslaunch that is compatible with xUnit frameworks"
+DESCRIPTION="Integration test suite based on roslaunch compatible with xUnit frameworks"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
dev-libs/boost:=[threads]
"
DEPEND="${RDEPEND}"
RDEPEND="${RDEPEND}
- dev-ros/roslib[${PYTHON_USEDEP}]
- dev-ros/rospy[${PYTHON_USEDEP}]
- dev-ros/roslaunch[${PYTHON_USEDEP}]
- dev-ros/rosmaster[${PYTHON_USEDEP}]"
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslaunch[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosmaster[${PYTHON_SINGLE_USEDEP}]"
DEPEND="${DEPEND}
test? (
${RDEPEND}
+ dev-ros/rosservice
dev-cpp/gtest
dev-ros/rostopic
)"