summaryrefslogtreecommitdiff
path: root/dev-ros/rosmsg
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosmsg')
-rw-r--r--dev-ros/rosmsg/Manifest2
-rw-r--r--dev-ros/rosmsg/rosmsg-1.15.11.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ros/rosmsg/Manifest b/dev-ros/rosmsg/Manifest
index 5a9d85d8368a..d1e595d420e3 100644
--- a/dev-ros/rosmsg/Manifest
+++ b/dev-ros/rosmsg/Manifest
@@ -1,4 +1,6 @@
DIST ros_comm-1.15.10.tar.gz 1089479 BLAKE2B 9855089aeb608466c3bff22676093c172e1e7898a1c1d7ab35cfffb948df4cb1324abbfc6c209df5944bee6265f24c53250c9bb0f811394bf276e33c19e81ee2 SHA512 34ac32a16eb170dae683e97dbc1528e1f0b2c3ddab9a84f2690ba92aa66639e0c99902ebc2e8e3e1aa5d6c97e6bd3d925f34827aa1943c3213eae2d211baf5a8
+DIST ros_comm-1.15.11.tar.gz 1089801 BLAKE2B 2ff05aa249dbdf5af2704efb52ef3fa12681e277f5e4fd0024645350bace6e41d3430ea727bc0d0e47ac1f946d8ef0b6b0c30e99a3695d67fd863bf9e01a8b3d SHA512 b8033ac96ebcd6a93c107dadd31b13fc48aab4cf2be9ebed0f773f94514b13cc395971eba9142aeb830251db7dd3df8a82d201b5663e9e1461b2ca792c981c99
EBUILD rosmsg-1.15.10.ebuild 1004 BLAKE2B 44fc7c48bd1c7180d2ad189969dc4ae3e7e77009f84361f0f75f328727fc0dfe4f97cf7d5ffbdb686359ecb69e371b45c41a57019d684e72ec3e64fc119141e4 SHA512 c04019456247c996ea0eb2600d28f7d5e298cb37ee784f433b67bff7185d36ec267e9d7d87419f956cfa4c31d42070446d2162049031bbfa071872a0f8e26f5f
+EBUILD rosmsg-1.15.11.ebuild 1004 BLAKE2B 44fc7c48bd1c7180d2ad189969dc4ae3e7e77009f84361f0f75f328727fc0dfe4f97cf7d5ffbdb686359ecb69e371b45c41a57019d684e72ec3e64fc119141e4 SHA512 c04019456247c996ea0eb2600d28f7d5e298cb37ee784f433b67bff7185d36ec267e9d7d87419f956cfa4c31d42070446d2162049031bbfa071872a0f8e26f5f
EBUILD rosmsg-9999.ebuild 1004 BLAKE2B 44fc7c48bd1c7180d2ad189969dc4ae3e7e77009f84361f0f75f328727fc0dfe4f97cf7d5ffbdb686359ecb69e371b45c41a57019d684e72ec3e64fc119141e4 SHA512 c04019456247c996ea0eb2600d28f7d5e298cb37ee784f433b67bff7185d36ec267e9d7d87419f956cfa4c31d42070446d2162049031bbfa071872a0f8e26f5f
MISC metadata.xml 326 BLAKE2B c8975866f4616482c71ac67084df89cea2643cc8233957c86450f7dba2ce320448e4e95fd1495c81717559d3fc5384dcc19f2182d3a348e4dcf2ea4d248e702e SHA512 6f647154c02825982d150588332801ad4c10c75cc5997b7825c0dd0381f48f6a3d09bf88346bc3e075891e77ca43a0a4c9f9c65962fd791085385c4229a1eb45
diff --git a/dev-ros/rosmsg/rosmsg-1.15.11.ebuild b/dev-ros/rosmsg/rosmsg-1.15.11.ebuild
new file mode 100644
index 000000000000..d4be4db4044c
--- /dev/null
+++ b/dev-ros/rosmsg/rosmsg-1.15.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Command-line tools for displaying information about message and services"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/genmsg[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ )
+"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}/../..:${EPREFIX}/usr/share/ros_packages/diagnostic_msgs:${EPREFIX}/usr/share/ros_packages/std_msgs:${EPREFIX}/usr/share/ros_packages/std_srvs"
+ ros-catkin_src_test
+}