summaryrefslogtreecommitdiff
path: root/dev-ros/rosmsg/rosmsg-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosmsg/rosmsg-9999.ebuild')
-rw-r--r--dev-ros/rosmsg/rosmsg-9999.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/dev-ros/rosmsg/rosmsg-9999.ebuild b/dev-ros/rosmsg/rosmsg-9999.ebuild
index ba0d62bb080b..d4be4db4044c 100644
--- a/dev-ros/rosmsg/rosmsg-9999.ebuild
+++ b/dev-ros/rosmsg/rosmsg-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -21,5 +21,15 @@ RDEPEND="
dev-ros/rosbag[${PYTHON_SINGLE_USEDEP}]
"
DEPEND="${RDEPEND}
- test? ( dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}] )
+ test? (
+ dev-ros/test_rosmaster[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ )
"
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}/../..:${EPREFIX}/usr/share/ros_packages/diagnostic_msgs:${EPREFIX}/usr/share/ros_packages/std_msgs:${EPREFIX}/usr/share/ros_packages/std_srvs"
+ ros-catkin_src_test
+}