summaryrefslogtreecommitdiff
path: root/dev-ros/rosauth
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosauth')
-rw-r--r--dev-ros/rosauth/Manifest4
-rw-r--r--dev-ros/rosauth/metadata.xml11
-rw-r--r--dev-ros/rosauth/rosauth-0.1.7.ebuild22
-rw-r--r--dev-ros/rosauth/rosauth-9999.ebuild22
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-ros/rosauth/Manifest b/dev-ros/rosauth/Manifest
new file mode 100644
index 000000000000..2c52a08e8f7e
--- /dev/null
+++ b/dev-ros/rosauth/Manifest
@@ -0,0 +1,4 @@
+DIST rosauth-0.1.7.tar.gz 6060 BLAKE2B 5b53de7f61d66c68ec91e64668dd8009d4c6087795efae8d96540c6db4a34480f8a262fc75f0b3bfc52817650157c5df921f077ffba4c972dca9461aff0dea58 SHA512 c52317cd173ec655b779f96ffe324cd136a54168484f26fff2a0d9fe2da6e25cc5109f1905d7528a9f6a433287873b63c53f96ec425ca6af740d4eea0b3250b5
+EBUILD rosauth-0.1.7.ebuild 521 BLAKE2B e666ba089ef09cc85f3fceead99d2bf9c366b72daade82cb341a6a8056c1749e3139b830384b886fac31e118dbfd900d1e1d22cc57c64d541d3ba11b83cd1214 SHA512 de1fdc087a008c79872a41081061c73d2f5168c8cb07c83874cd1c5d9ae2ad2adbea95daf34b6af611664c133b0d7fb8c733ab28b793a076f69352715c437b42
+EBUILD rosauth-9999.ebuild 521 BLAKE2B e666ba089ef09cc85f3fceead99d2bf9c366b72daade82cb341a6a8056c1749e3139b830384b886fac31e118dbfd900d1e1d22cc57c64d541d3ba11b83cd1214 SHA512 de1fdc087a008c79872a41081061c73d2f5168c8cb07c83874cd1c5d9ae2ad2adbea95daf34b6af611664c133b0d7fb8c733ab28b793a076f69352715c437b42
+MISC metadata.xml 330 BLAKE2B b7647904cd15b02dd3107c10d156d5dc9ff7dec2dd67014402afe7b2f99ecc127f07bf971ff40a86ae0f414f43750ffda75f1814802c689816da11ed1bd0f6f1 SHA512 de7596aebaeef7ac6d148cb8c88573f98c76b28fa6adbd322260ea28c96ed58315c7e855941f572bf3d10b5351acd545dfcfc92d02fdad5b34e7824e72e29070
diff --git a/dev-ros/rosauth/metadata.xml b/dev-ros/rosauth/metadata.xml
new file mode 100644
index 000000000000..e8a311eb20f2
--- /dev/null
+++ b/dev-ros/rosauth/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">WPI-RAIL/rosauth</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/rosauth/rosauth-0.1.7.ebuild b/dev-ros/rosauth/rosauth-0.1.7.ebuild
new file mode 100644
index 000000000000..372b30e6a355
--- /dev/null
+++ b/dev-ros/rosauth/rosauth-0.1.7.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/WPI-RAIL/rosauth"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Server Side tools for Authorization and Authentication of ROS Clients"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"
diff --git a/dev-ros/rosauth/rosauth-9999.ebuild b/dev-ros/rosauth/rosauth-9999.ebuild
new file mode 100644
index 000000000000..372b30e6a355
--- /dev/null
+++ b/dev-ros/rosauth/rosauth-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/WPI-RAIL/rosauth"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Server Side tools for Authorization and Authentication of ROS Clients"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"