summaryrefslogtreecommitdiff
path: root/dev-ros/rosauth/rosauth-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosauth/rosauth-9999.ebuild')
-rw-r--r--dev-ros/rosauth/rosauth-9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/rosauth/rosauth-9999.ebuild b/dev-ros/rosauth/rosauth-9999.ebuild
new file mode 100644
index 000000000000..372b30e6a355
--- /dev/null
+++ b/dev-ros/rosauth/rosauth-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/WPI-RAIL/rosauth"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Server Side tools for Authorization and Authentication of ROS Clients"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-libs/openssl:0="
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"