summaryrefslogtreecommitdiff
path: root/dev-ros/resource_retriever/resource_retriever-1.12.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/resource_retriever/resource_retriever-1.12.7.ebuild')
-rw-r--r--dev-ros/resource_retriever/resource_retriever-1.12.7.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-ros/resource_retriever/resource_retriever-1.12.7.ebuild b/dev-ros/resource_retriever/resource_retriever-1.12.7.ebuild
deleted file mode 100644
index 1ce7de9a14ac..000000000000
--- a/dev-ros/resource_retriever/resource_retriever-1.12.7.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/ros/resource_retriever"
-KEYWORDS="~amd64 ~arm"
-
-inherit ros-catkin
-
-DESCRIPTION="Retrieves data from url-format files"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/rosconsole
- dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
- net-misc/curl
- $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
-"
-DEPEND="${RDEPEND}
- test? ( dev-cpp/gtest )"
-
-src_test() {
- export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
- if has network-sandbox ${FEATURES}; then
- einfo "Skipping network tests due to network sandbox"
- export GTEST_FILTER='-Retriever.http'
- export NOSE_TESTMATCH='^(?!test_http).*'
- fi
- ros-catkin_src_test
-}