summaryrefslogtreecommitdiff
path: root/dev-ros/resource_retriever/resource_retriever-1.12.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/resource_retriever/resource_retriever-1.12.3.ebuild')
-rw-r--r--dev-ros/resource_retriever/resource_retriever-1.12.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/resource_retriever/resource_retriever-1.12.3.ebuild b/dev-ros/resource_retriever/resource_retriever-1.12.3.ebuild
new file mode 100644
index 000000000000..594a7791b4d1
--- /dev/null
+++ b/dev-ros/resource_retriever/resource_retriever-1.12.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/resource_retriever"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Retrieves data from url-format files"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ net-misc/curl
+ dev-python/rospkg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"