summaryrefslogtreecommitdiff
path: root/dev-ros/realtime_tools/realtime_tools-1.16.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/realtime_tools/realtime_tools-1.16.1.ebuild')
-rw-r--r--dev-ros/realtime_tools/realtime_tools-1.16.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/realtime_tools/realtime_tools-1.16.1.ebuild b/dev-ros/realtime_tools/realtime_tools-1.16.1.ebuild
new file mode 100644
index 000000000000..7461e643ffec
--- /dev/null
+++ b/dev-ros/realtime_tools/realtime_tools-1.16.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-controls/realtime_tools"
+KEYWORDS="~amd64"
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools that can be used from a hard realtime thread"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-cpp/gtest
+ dev-ros/actionlib
+ )
+"
+PATCHES=( "${FILESDIR}/atomic.patch" )