summaryrefslogtreecommitdiff
path: root/dev-ros/octomap_ros
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/octomap_ros')
-rw-r--r--dev-ros/octomap_ros/Manifest4
-rw-r--r--dev-ros/octomap_ros/metadata.xml11
-rw-r--r--dev-ros/octomap_ros/octomap_ros-0.4.0-r1.ebuild22
-rw-r--r--dev-ros/octomap_ros/octomap_ros-9999.ebuild22
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-ros/octomap_ros/Manifest b/dev-ros/octomap_ros/Manifest
new file mode 100644
index 000000000000..36333bfd3c10
--- /dev/null
+++ b/dev-ros/octomap_ros/Manifest
@@ -0,0 +1,4 @@
+DIST octomap_ros-0.4.0.tar.gz 5076 BLAKE2B 4c1431d139e7025cae3ac9fa41fa86c71690be58d3177a3a4694f62affc2d61a73eeb456ab78b17c6b63ece8cf9582cff179c4f73ba3520e792a1e819e5ee69b SHA512 41910879d042dcbd969544e89fe40c1da8be75118ef1b813e3cb0319b83529a9c759fe99ed430b275d10d5df987bed7e2b4d7300ed561d159b6007de306bc8ce
+EBUILD octomap_ros-0.4.0-r1.ebuild 509 BLAKE2B 358e20cbdfa9c9662bd7de637aba0660dacee5e233896ddf9c476ea0b8dd3ab4a120e6295a71d1628d2ce01f5adc74dda4d7104219ea8ed421b53dcc284eeebf SHA512 2db338b29533ed7103a0eaa23289d5744d55909ff246a867d7369b1eedfb4fed647ef169400306ffd377192695333b80a6352be3c8d78ea8a2c4e1eda97c4c8c
+EBUILD octomap_ros-9999.ebuild 509 BLAKE2B 358e20cbdfa9c9662bd7de637aba0660dacee5e233896ddf9c476ea0b8dd3ab4a120e6295a71d1628d2ce01f5adc74dda4d7104219ea8ed421b53dcc284eeebf SHA512 2db338b29533ed7103a0eaa23289d5744d55909ff246a867d7369b1eedfb4fed647ef169400306ffd377192695333b80a6352be3c8d78ea8a2c4e1eda97c4c8c
+MISC metadata.xml 333 BLAKE2B 0997902e45c25ffbdac0d4a065c63a5adf108ffc126c133ce6e5e8776ad7319d6458dfa19ce1aac238d9b522abbab9ab60d29a29c0d5cafa53322cc481fa0964 SHA512 6ae210514f0405e56fdefc8db22fc196de2648d687163e3d55bec4c0fa8d950bf60b7d7b4220f56d545ccbd88ac1b5e6075673a01ab4c6b69f7febde8bf33362
diff --git a/dev-ros/octomap_ros/metadata.xml b/dev-ros/octomap_ros/metadata.xml
new file mode 100644
index 000000000000..b4e22aa4e97f
--- /dev/null
+++ b/dev-ros/octomap_ros/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">OctoMap/octomap_ros</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/octomap_ros/octomap_ros-0.4.0-r1.ebuild b/dev-ros/octomap_ros/octomap_ros-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..b73677241874
--- /dev/null
+++ b/dev-ros/octomap_ros/octomap_ros-0.4.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/OctoMap/octomap_ros"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Conversion functions between ROS / PCL and OctoMap's native types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/pcl_ros
+ sci-libs/octomap
+ dev-ros/octomap_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/octomap_ros/octomap_ros-9999.ebuild b/dev-ros/octomap_ros/octomap_ros-9999.ebuild
new file mode 100644
index 000000000000..b73677241874
--- /dev/null
+++ b/dev-ros/octomap_ros/octomap_ros-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/OctoMap/octomap_ros"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Conversion functions between ROS / PCL and OctoMap's native types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/pcl_ros
+ sci-libs/octomap
+ dev-ros/octomap_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"