summaryrefslogtreecommitdiff
path: root/dev-ros/navfn/navfn-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/navfn/navfn-9999.ebuild')
-rw-r--r--dev-ros/navfn/navfn-9999.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-ros/navfn/navfn-9999.ebuild b/dev-ros/navfn/navfn-9999.ebuild
index da9427d6977b..a65e0eb3f75f 100644
--- a/dev-ros/navfn/navfn-9999.ebuild
+++ b/dev-ros/navfn/navfn-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -36,4 +36,9 @@ DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )
dev-ros/cmake_modules"
-PATCHES=( "${FILESDIR}/pgm_h_location.patch" )
+PATCHES=( "${FILESDIR}/pgm_h_location.patch" "${FILESDIR}/tests.patch" )
+
+src_prepare() {
+ ros-catkin_src_prepare
+ sed -e "s#@PGM_PATH@#\"${S}/test/willow_costmap.pgm\"#" -i test/path_calc_test.cpp || die
+}