summaryrefslogtreecommitdiff
path: root/dev-ros/imu_transformer/imu_transformer-0.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/imu_transformer/imu_transformer-0.2.2.ebuild')
-rw-r--r--dev-ros/imu_transformer/imu_transformer-0.2.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/imu_transformer/imu_transformer-0.2.2.ebuild b/dev-ros/imu_transformer/imu_transformer-0.2.2.ebuild
new file mode 100644
index 000000000000..fd0c298cbf92
--- /dev/null
+++ b/dev-ros/imu_transformer/imu_transformer-0.2.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/imu_pipeline"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Node/nodelet combination to transform sensor_msgs::Imu data from one frame into another"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/roslaunch
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/topic_tools
+ dev-ros/tf2_sensor_msgs
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"