summaryrefslogtreecommitdiff
path: root/dev-ros/imu_filter_madgwick
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/imu_filter_madgwick')
-rw-r--r--dev-ros/imu_filter_madgwick/Manifest7
-rw-r--r--dev-ros/imu_filter_madgwick/files/pluginlib.patch10
-rw-r--r--dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.1.5-r1.ebuild34
-rw-r--r--dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.2.0.ebuild33
-rw-r--r--dev-ros/imu_filter_madgwick/imu_filter_madgwick-9999.ebuild33
-rw-r--r--dev-ros/imu_filter_madgwick/metadata.xml11
6 files changed, 128 insertions, 0 deletions
diff --git a/dev-ros/imu_filter_madgwick/Manifest b/dev-ros/imu_filter_madgwick/Manifest
new file mode 100644
index 000000000000..d6ac94b16a5f
--- /dev/null
+++ b/dev-ros/imu_filter_madgwick/Manifest
@@ -0,0 +1,7 @@
+AUX pluginlib.patch 498 BLAKE2B 923d0288c75d969156cc5825c624e041821492c0d767873685ca8d479759cc1ded1d30cb22091b45066a8ea57fb2abcccc5acd852bc0f778a203b99760e466f1 SHA512 59e3d0c7e9c7b1dde87e430cee2084afa2c3e443277322c2c21abfe9619392d88d321b90198f03b5e90f8e3d4eb184611c0839ffdb93ca275d6e20db08e4acf5
+DIST imu_tools-1.1.5.tar.gz 1653083 BLAKE2B 8c0e84333455a5b4cae215a2e54b74ff828d00a426b9ab13f4048a72556b6a526dc4256a53dc3e21e098cc31ea6d21e0d508066a4627d01c27681ce0b3b18035 SHA512 5009884852c71d6bb1b6c2be2f30ed333eca2ac6a7f29d02cb8f0821c0b95a33dd3b09049c4c4eeb1416fb0eb5dc454b3c6d36c2c24303f37c0d1d2c0c2d906a
+DIST imu_tools-1.2.0.tar.gz 1653607 BLAKE2B 76cccfeae657188e3be3774bcb19c5edac94e7070a6fd8a01c8a56857297491568f978820e6f32467b031ceece4742e6c0fe926e5d59ad19a2f6fb1c037ac3ec SHA512 3f39a2ec539949a6881cc106122d663706ddd3ed03ed822b9370e56beb56f1349bfd668a71e443ab2b9d525c6a3a88fad053768764160d9d0f04c08ba1ad2f8e
+EBUILD imu_filter_madgwick-1.1.5-r1.ebuild 797 BLAKE2B c561d840818d5aee7e61a14c076b402c83ab97ec0d6b9f671129723cc4e86f57e953e9ccbbeba362291cbf1b1561990515dcb7f1768813d0f29739117352ee14 SHA512 ab75f6871c652b1852abb67a6f633faf6048782e0924d00ae48ea2bcc6c116c13b1a6dc6cd2aed51ff554b83a9332c933d94b1a0b46e06638dc9bef46d4dfda8
+EBUILD imu_filter_madgwick-1.2.0.ebuild 755 BLAKE2B d9db5fb169aba977dbe2c7b6d67c050938e72bee39137503c79cea7a110aa7d3ab1e66e781e38636113adb2c6b590dd7bbe3ecdec3fb1ea83db96b6116cd38e5 SHA512 88428a38e0ebeefab1df6d2057b808e04b7d6ba88c430934d1cf6aed0f076f5045c227ef17cf4eabd068e3036d775e43b6ecbe21a0fad4cef0e6044607b0c6e2
+EBUILD imu_filter_madgwick-9999.ebuild 755 BLAKE2B dea2ac8e4c97538fddf1d11eb038196677a469352bca4b9a994ff6d4aa05e5471e036ae93e7c303340c1a5f412b49246d193c4804667f9a6e6a5427909a28991 SHA512 fca79c2a9a0308ed99c5c2acde0a66285dfd08ba60cdc974df9a0dfac864ee6999902b321fb6b21de1989358527e578e778b181fb41868c38c4b6f83244bc2e5
+MISC metadata.xml 336 BLAKE2B 9f0036577f511b6a36a278270167ff44a45d958d73979fc5725cd56cc8eb6dc1228e289837c2dfbcd2a23af9679f9f633c9256315850ee734ec651fcce3a8e1e SHA512 12de24345100b9c879928c76d15db9215d340f68854ba09f5ff57b043ec90c2c0ef8bda03d9dc306141cb7d653601a9a3155224d60030284cff4242f7ddc07aa
diff --git a/dev-ros/imu_filter_madgwick/files/pluginlib.patch b/dev-ros/imu_filter_madgwick/files/pluginlib.patch
new file mode 100644
index 000000000000..26e77bb3ffcf
--- /dev/null
+++ b/dev-ros/imu_filter_madgwick/files/pluginlib.patch
@@ -0,0 +1,10 @@
+Index: imu_filter_madgwick/src/imu_filter_nodelet.cpp
+===================================================================
+--- imu_filter_madgwick.orig/src/imu_filter_nodelet.cpp
++++ imu_filter_madgwick/src/imu_filter_nodelet.cpp
+@@ -36,4 +36,4 @@ void ImuFilterNodelet::onInit()
+ filter_.reset(new ImuFilterRos(nh, nh_private));
+ }
+
+-PLUGINLIB_DECLARE_CLASS(imu_filter_madgwick, ImuFilterNodelet, ImuFilterNodelet, nodelet::Nodelet);
++PLUGINLIB_EXPORT_CLASS(ImuFilterNodelet, nodelet::Nodelet);
diff --git a/dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.1.5-r1.ebuild b/dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.1.5-r1.ebuild
new file mode 100644
index 000000000000..8d3eedf16d3f
--- /dev/null
+++ b/dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.1.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+ dev-ros/tf2_ros
+ dev-ros/nodelet
+ dev-libs/console_bridge:=
+ dev-ros/pluginlib
+ dev-ros/message_filters
+ dev-ros/dynamic_reconfigure
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rosunit )
+"
+PATCHES=( "${FILESDIR}/pluginlib.patch" )
diff --git a/dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.2.0.ebuild b/dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.2.0.ebuild
new file mode 100644
index 000000000000..1594d52649aa
--- /dev/null
+++ b/dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+ dev-ros/tf2_ros
+ dev-ros/nodelet
+ dev-libs/console_bridge:=
+ dev-ros/pluginlib
+ dev-ros/message_filters
+ dev-ros/dynamic_reconfigure
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rosunit )
+"
diff --git a/dev-ros/imu_filter_madgwick/imu_filter_madgwick-9999.ebuild b/dev-ros/imu_filter_madgwick/imu_filter_madgwick-9999.ebuild
new file mode 100644
index 000000000000..d66fb87d71cd
--- /dev/null
+++ b/dev-ros/imu_filter_madgwick/imu_filter_madgwick-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_geometry_msgs
+ dev-ros/tf2_ros
+ dev-ros/nodelet
+ dev-libs/console_bridge:=
+ dev-ros/pluginlib
+ dev-ros/message_filters
+ dev-ros/dynamic_reconfigure
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rosunit )
+"
diff --git a/dev-ros/imu_filter_madgwick/metadata.xml b/dev-ros/imu_filter_madgwick/metadata.xml
new file mode 100644
index 000000000000..0be33667fd34
--- /dev/null
+++ b/dev-ros/imu_filter_madgwick/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ccny-ros-pkg/imu_tools</remote-id>
+ </upstream>
+</pkgmetadata>