summaryrefslogtreecommitdiff
path: root/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild')
-rw-r--r--dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild b/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
new file mode 100644
index 000000000000..7cc3dd4e6490
--- /dev/null
+++ b/dev-ros/hector_pose_estimation/hector_pose_estimation-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="hector_pose_estimation node and the hector_pose_estimation nodelet"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/hector_pose_estimation_core
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+# dev-ros/hector_timing
+DEPEND="${RDEPEND}"