summaryrefslogtreecommitdiff
path: root/dev-ros/hector_map_server
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/hector_map_server')
-rw-r--r--dev-ros/hector_map_server/Manifest4
-rw-r--r--dev-ros/hector_map_server/hector_map_server-0.3.5.ebuild25
-rw-r--r--dev-ros/hector_map_server/hector_map_server-9999.ebuild25
-rw-r--r--dev-ros/hector_map_server/metadata.xml11
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-ros/hector_map_server/Manifest b/dev-ros/hector_map_server/Manifest
new file mode 100644
index 000000000000..a75528dac074
--- /dev/null
+++ b/dev-ros/hector_map_server/Manifest
@@ -0,0 +1,4 @@
+DIST hector_slam-0.3.5.tar.gz 66002 BLAKE2B 6e370fedf49b450cd3dec77eb7a197cc13796d787c41a72d5bdf918661728e96ff9e388ab1f2c5cf64c13ff6e94e058fc4c8ba176307b63cc51b892c0183dd54 SHA512 7f61c6b0607295b6b96fb9cadbaafc7531013a0d7cfaab19630c14ac52cde8920376a57041577d2c9945130200ce5912ba331dd1e3d0f41297a928a34a45dfa1
+EBUILD hector_map_server-0.3.5.ebuild 610 BLAKE2B 71437b223d9d430ad2f94398f850feb8e0547a5cadbc1f0fb92c839d867d957168ea2801170b5da8b035a172b63d05a83b5d2cec197c290c1c6854ee91a567d6 SHA512 7c2687184ca357989bead7b3ac30319c14c7768645a1b7f764f7a5953215184fda3c6cd0d689fdf068f4614b061a5dcd3258e9a771b14b94d60de8c2bd7997de
+EBUILD hector_map_server-9999.ebuild 610 BLAKE2B 71437b223d9d430ad2f94398f850feb8e0547a5cadbc1f0fb92c839d867d957168ea2801170b5da8b035a172b63d05a83b5d2cec197c290c1c6854ee91a567d6 SHA512 7c2687184ca357989bead7b3ac30319c14c7768645a1b7f764f7a5953215184fda3c6cd0d689fdf068f4614b061a5dcd3258e9a771b14b94d60de8c2bd7997de
+MISC metadata.xml 346 BLAKE2B 2c19759ef75680fbdf13a2782c7ab61ce35df604fdc577f03e538cf599ab5bdd8c18c3abb14411c19148d96b086efd7f1ce4c851243085ecf5a429c20d0eca88 SHA512 7e8f72ba74709122f67811e4d0945757dd30c8bc266d95198293260631d0d0eb2063d19996e6dffa4e0184f5bda1e3bd44b6bee6956b58dcebc6919ff64199bb
diff --git a/dev-ros/hector_map_server/hector_map_server-0.3.5.ebuild b/dev-ros/hector_map_server/hector_map_server-0.3.5.ebuild
new file mode 100644
index 000000000000..5b5d6a35bb53
--- /dev/null
+++ b/dev-ros/hector_map_server/hector_map_server-0.3.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Service for retrieving the map, as well as for raycasting based obstacle queries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/hector_map_tools
+ dev-ros/hector_marker_drawing
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/hector_map_server/hector_map_server-9999.ebuild b/dev-ros/hector_map_server/hector_map_server-9999.ebuild
new file mode 100644
index 000000000000..5b5d6a35bb53
--- /dev/null
+++ b/dev-ros/hector_map_server/hector_map_server-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Service for retrieving the map, as well as for raycasting based obstacle queries"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/hector_map_tools
+ dev-ros/hector_marker_drawing
+ dev-ros/hector_nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/hector_map_server/metadata.xml b/dev-ros/hector_map_server/metadata.xml
new file mode 100644
index 000000000000..29147f0be960
--- /dev/null
+++ b/dev-ros/hector_map_server/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tu-darmstadt-ros-pkg/hector_slam</remote-id>
+ </upstream>
+</pkgmetadata>