summaryrefslogtreecommitdiff
path: root/dev-ros/driver_base/driver_base-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/driver_base/driver_base-9999.ebuild')
-rw-r--r--dev-ros/driver_base/driver_base-9999.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/driver_base/driver_base-9999.ebuild b/dev-ros/driver_base/driver_base-9999.ebuild
new file mode 100644
index 000000000000..a156ea82b8e5
--- /dev/null
+++ b/dev-ros/driver_base/driver_base-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/driver_common"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Framework for writing drivers that helps with runtime reconfiguration, diagnostics and self-test"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}"