summaryrefslogtreecommitdiff
path: root/dev-ros/depthimage_to_laserscan
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/depthimage_to_laserscan')
-rw-r--r--dev-ros/depthimage_to_laserscan/Manifest6
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild28
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild28
-rw-r--r--dev-ros/depthimage_to_laserscan/files/isnan.patch13
-rw-r--r--dev-ros/depthimage_to_laserscan/files/pluginlib.patch11
-rw-r--r--dev-ros/depthimage_to_laserscan/metadata.xml11
6 files changed, 97 insertions, 0 deletions
diff --git a/dev-ros/depthimage_to_laserscan/Manifest b/dev-ros/depthimage_to_laserscan/Manifest
new file mode 100644
index 000000000000..7aae46634c37
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/Manifest
@@ -0,0 +1,6 @@
+AUX isnan.patch 672 BLAKE2B 714348340fb583106891e467fb24815cb95e389ef863b39c8ed5d6250c2fc5d5467cf565590b0fa1e163c440fd6e282f6320d77395b676876bd51526a755e454 SHA512 c4993894868cbfbd66374b4062f43e7d58ef8e3d725024b06146144809cd059d6a01ba502626876089847688a58f1f069f8dfb788e657ac7c1a79e9cb8200a7b
+AUX pluginlib.patch 616 BLAKE2B 7ba7ce7e1af6b5f97987011a5f65edc200bcb56904cda31bbfb3e35a5a0ae5250bdef3d207cbcf7cd67a83a0aa04858162116631fdc1399159188d3168338d19 SHA512 f0ad07597c7b375e7b7ba566e19c21ef73a8cee9f7f124b0819056d061dd7a6e6b5a583ac6d9bfd66ced8e6bf4823e11867581789e2c82aa455e229291f26244
+DIST depthimage_to_laserscan-1.0.7.tar.gz 12121 BLAKE2B f8b69ce10311e39eaf963c42fd6ea653c8b0fe1c2381ab128d575d490d236b03d8667a213e8e9eb9423c4a9244697fb9746ebe8385ac0142776e47063fe9e5bf SHA512 4da5fa446d574dbb44c2924dd760f160e527e68d7df119e5d9e74d85efd3473ee31845e8565b0d023d2cf22c945b3b5c56b12a04facd4e38dc3dd1235dad73e9
+EBUILD depthimage_to_laserscan-1.0.7-r2.ebuild 733 BLAKE2B b34108683225362e8c46286ab6f0b68b29173e3f2cf658732bfb2c344d43071bfeefa6a37a9612ccf0cf8a9f79ca2d8c6c31d02f32d899e0db06cfea6b3c7c33 SHA512 eafc77e18ea8ae75459fa5f630ee82ea65df62ba0d0a4996b544d842ab5edcb78556a6b1e15245ab9ab881744fae64ded2cc0e8603fde9978d7593dc32d1e4ec
+EBUILD depthimage_to_laserscan-9999.ebuild 733 BLAKE2B b34108683225362e8c46286ab6f0b68b29173e3f2cf658732bfb2c344d43071bfeefa6a37a9612ccf0cf8a9f79ca2d8c6c31d02f32d899e0db06cfea6b3c7c33 SHA512 eafc77e18ea8ae75459fa5f630ee82ea65df62ba0d0a4996b544d842ab5edcb78556a6b1e15245ab9ab881744fae64ded2cc0e8603fde9978d7593dc32d1e4ec
+MISC metadata.xml 352 BLAKE2B 925e18de2139370d06d242cbf4c2d15f2d201df3c28036169eb868defaad60ef0e38814cae627c43efbe5efddfa21e311053970f7ad0b648650df538c1817a10 SHA512 3eafc06a8ac658f3f29903c2f23b88b53b2dd5b1a70fecb8788a4027646c5367a3d0384179c0ca1e75e58a8081ce53c00ae6def249f48a7fc7c2ea0365408d2c
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild
new file mode 100644
index 000000000000..2e621e904b7b
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a depth image to a laser scan for use with navigation and localization"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/isnan.patch" "${FILESDIR}/pluginlib.patch" )
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
new file mode 100644
index 000000000000..2e621e904b7b
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a depth image to a laser scan for use with navigation and localization"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/isnan.patch" "${FILESDIR}/pluginlib.patch" )
diff --git a/dev-ros/depthimage_to_laserscan/files/isnan.patch b/dev-ros/depthimage_to_laserscan/files/isnan.patch
new file mode 100644
index 000000000000..11254904e945
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/files/isnan.patch
@@ -0,0 +1,13 @@
+Index: depthimage_to_laserscan-1.0.7/src/DepthImageToLaserScan.cpp
+===================================================================
+--- depthimage_to_laserscan-1.0.7.orig/src/DepthImageToLaserScan.cpp
++++ depthimage_to_laserscan-1.0.7/src/DepthImageToLaserScan.cpp
+@@ -59,7 +59,7 @@ bool DepthImageToLaserScan::use_point(co
+
+ // Infs are preferable over NaNs (more information)
+ if(!new_finite && !old_finite){ // Both are not NaN or Inf.
+- if(!isnan(new_value)){ // new is not NaN, so use it's +-Inf value.
++ if(!std::isnan(new_value)){ // new is not NaN, so use it's +-Inf value.
+ return true;
+ }
+ return false; // Do not replace old_value
diff --git a/dev-ros/depthimage_to_laserscan/files/pluginlib.patch b/dev-ros/depthimage_to_laserscan/files/pluginlib.patch
new file mode 100644
index 000000000000..a367cd40c5f6
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/files/pluginlib.patch
@@ -0,0 +1,11 @@
+Index: depthimage_to_laserscan-1.0.7/src/DepthImageToLaserScanNodelet.cpp
+===================================================================
+--- depthimage_to_laserscan-1.0.7.orig/src/DepthImageToLaserScanNodelet.cpp
++++ depthimage_to_laserscan-1.0.7/src/DepthImageToLaserScanNodelet.cpp
+@@ -57,5 +57,5 @@ private:
+ }
+
+ #include <pluginlib/class_list_macros.h>
+-PLUGINLIB_DECLARE_CLASS(depthimage_to_laserscan, DepthImageToLaserScanNodelet, depthimage_to_laserscan::DepthImageToLaserScanNodelet, nodelet::Nodelet);
++PLUGINLIB_EXPORT_CLASS(depthimage_to_laserscan::DepthImageToLaserScanNodelet, nodelet::Nodelet)
+
diff --git a/dev-ros/depthimage_to_laserscan/metadata.xml b/dev-ros/depthimage_to_laserscan/metadata.xml
new file mode 100644
index 000000000000..4b338e1e4325
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/depthimage_to_laserscan</remote-id>
+ </upstream>
+</pkgmetadata>