summaryrefslogtreecommitdiff
path: root/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild')
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild
new file mode 100644
index 000000000000..2e621e904b7b
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-1.0.7-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a depth image to a laser scan for use with navigation and localization"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ media-libs/opencv:=
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/isnan.patch" "${FILESDIR}/pluginlib.patch" )