summaryrefslogtreecommitdiff
path: root/dev-ros/compressed_depth_image_transport
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/compressed_depth_image_transport')
-rw-r--r--dev-ros/compressed_depth_image_transport/Manifest4
-rw-r--r--dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.9.5-r1.ebuild25
-rw-r--r--dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild25
-rw-r--r--dev-ros/compressed_depth_image_transport/metadata.xml11
4 files changed, 65 insertions, 0 deletions
diff --git a/dev-ros/compressed_depth_image_transport/Manifest b/dev-ros/compressed_depth_image_transport/Manifest
new file mode 100644
index 000000000000..f488283a7af9
--- /dev/null
+++ b/dev-ros/compressed_depth_image_transport/Manifest
@@ -0,0 +1,4 @@
+DIST image_transport_plugins-1.9.5.tar.gz 26268 BLAKE2B 2d7e71f891bc3ae548193a9671fb10fb4dc6c7a24fda0c0dc52d75d43793d55e35da37155496740624e4ebe34fcf0e8d3926345ca1581fa521096c01b773f551 SHA512 54f459719a386f028578889f9b88b8b080f495d75899cee6c8bfb58204970fb2395b2a8da70034eb391ba62f4ce462cb89b97bcdc576a177444613076b5ed02c
+EBUILD compressed_depth_image_transport-1.9.5-r1.ebuild 599 BLAKE2B a522cfae31f5b06a5c71893ec4219a50f108f6cab778cf6af8f819c3bd9929fa4f12825eb9e4dccdaa2679975e4cd30e19ed9057875c9370e847c9761ca4d0bf SHA512 f7e0dbab6bf3f1bd59e90d5569b4df97ba210fafe2883f2125c98da1675b1203d84790ee1e10958f7912eef478d29235735b0d3e246006bc40aedbeaba14583d
+EBUILD compressed_depth_image_transport-9999.ebuild 599 BLAKE2B a522cfae31f5b06a5c71893ec4219a50f108f6cab778cf6af8f819c3bd9929fa4f12825eb9e4dccdaa2679975e4cd30e19ed9057875c9370e847c9761ca4d0bf SHA512 f7e0dbab6bf3f1bd59e90d5569b4df97ba210fafe2883f2125c98da1675b1203d84790ee1e10958f7912eef478d29235735b0d3e246006bc40aedbeaba14583d
+MISC metadata.xml 352 BLAKE2B d741d3235de6a630917b5785819ea9a3b13d8602bc5fd27b9fb8d4cea1df216fb64eaa0fd2fee5c5f11012a823311155331e2ae65af23874322679dc57bc32a9 SHA512 855c756eea98c52acb020fb394646008db35b41b864a0983f67bbf07ffce658d394c0de13d6622286770e4aa4152b74f2f6028c575b11b66233431d1fffa0347
diff --git a/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.9.5-r1.ebuild b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.9.5-r1.ebuild
new file mode 100644
index 000000000000..d4ef693e9dd2
--- /dev/null
+++ b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-1.9.5-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending depth images using PNG compression"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_transport
+ media-libs/opencv:=
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild
new file mode 100644
index 000000000000..d4ef693e9dd2
--- /dev/null
+++ b/dev-ros/compressed_depth_image_transport/compressed_depth_image_transport-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_transport_plugins"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Plugin to image_transport for transparently sending depth images using PNG compression"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_transport
+ media-libs/opencv:=
+ dev-libs/boost:=
+ dev-libs/console_bridge:=
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/compressed_depth_image_transport/metadata.xml b/dev-ros/compressed_depth_image_transport/metadata.xml
new file mode 100644
index 000000000000..feed05c03f5b
--- /dev/null
+++ b/dev-ros/compressed_depth_image_transport/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/image_transport_plugins</remote-id>
+ </upstream>
+</pkgmetadata>