summaryrefslogtreecommitdiff
path: root/dev-ros/calibration_estimation
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/calibration_estimation')
-rw-r--r--dev-ros/calibration_estimation/Manifest4
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild42
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-9999.ebuild4
3 files changed, 46 insertions, 4 deletions
diff --git a/dev-ros/calibration_estimation/Manifest b/dev-ros/calibration_estimation/Manifest
index 69d9aadbab74..4bdae2875ed9 100644
--- a/dev-ros/calibration_estimation/Manifest
+++ b/dev-ros/calibration_estimation/Manifest
@@ -1,5 +1,7 @@
AUX py3.patch 3416 BLAKE2B 7f879cee3a10359d5988fe8ee04ccfb9c2d30fff7609e52950c7a61c3f02ad571363094f47e841ef9796c49c0d14f75c275cf3ba7534a5a0c1c0680ec48a2c70 SHA512 6200c57aa4f6f95338eba80342efcdd026b971d3b373a946fd45ce92bddc67f329c1fcafcedc74f2169ce871565a91b1d442a862cd5f87cd99f9aa225304b15f
DIST calibration-0.10.14.tar.gz 112475 BLAKE2B a43bf316b3eea30f5f3e273e0dd2754fe819a1aa246237cb1ecc4bc49463abbd3eb71f77579fc0655c483ad9ac259bb027ac014fc5ec368a73bada61dedf6712 SHA512 5ef17cd21e04c134717859ecb12c4e7fc0086b044cf7d35d40bd43439a0f24e8ad41fe7b5fa37dcc8ec5e4abb2be8f64d86510706a3d97510cf1b92c2196ad40
+DIST calibration-0.10.15.tar.gz 115940 BLAKE2B 43c8564ad8f15894d04571fbb3c6bc2059a5d232de3fb6225b715b078a11fef2e19283e3f0587ed47f2d52784ade22bebdf4680f6b30c585da2fbbfa1c45b0a5 SHA512 06ffc9ae6872b914eb6954996d165e2aa65d786756896a21be1ab3b5c20f1df3340e2fdf9804bc3cd78089f5b2e05eaed2a4376e70e98ccaaa8a88d95c3f4894
EBUILD calibration_estimation-0.10.14.ebuild 1371 BLAKE2B 2dd06306d99468d2670da4c706ed3cea54239a01cf3a4311c0364a0f0b50dbc171fc4bac4950d145b15ea6bf720a06fdc2377276b3966f3acc96a569e985b2a9 SHA512 6e001af223d114e5cfbd1ad5f96e4bdaab495e6a6fd766ac4f553670b6d3eb18a05d0665ccb10181cbe7914e088ab73152b9347003c4408697499702820b9afb
-EBUILD calibration_estimation-9999.ebuild 1371 BLAKE2B 2dd06306d99468d2670da4c706ed3cea54239a01cf3a4311c0364a0f0b50dbc171fc4bac4950d145b15ea6bf720a06fdc2377276b3966f3acc96a569e985b2a9 SHA512 6e001af223d114e5cfbd1ad5f96e4bdaab495e6a6fd766ac4f553670b6d3eb18a05d0665ccb10181cbe7914e088ab73152b9347003c4408697499702820b9afb
+EBUILD calibration_estimation-0.10.15.ebuild 1285 BLAKE2B 71e12a96ee250844b0172a6d70913112feed42cdbdebedabe2a33e88c4f68d94c67201ee844b0e2c0616257158de2159c8dfd5003c50682d1efe6fa8abc6742a SHA512 f2a2ea46508e763285bc9f9e6aa15ca905c00f5b09162986f80e0a0ffeba0ec350027be7feedb61152163d6c73298dbcea03a5d6c009bf725fa9ebc456882c51
+EBUILD calibration_estimation-9999.ebuild 1285 BLAKE2B 71e12a96ee250844b0172a6d70913112feed42cdbdebedabe2a33e88c4f68d94c67201ee844b0e2c0616257158de2159c8dfd5003c50682d1efe6fa8abc6742a SHA512 f2a2ea46508e763285bc9f9e6aa15ca905c00f5b09162986f80e0a0ffeba0ec350027be7feedb61152163d6c73298dbcea03a5d6c009bf725fa9ebc456882c51
MISC metadata.xml 340 BLAKE2B 52b47839e0051b2f1813313ae3989819be9668c093763a9c9518302d5b5832142fd02e6c7427493411d2b3ad3143d41180aa1c0f890362b43258109fc5b858b3 SHA512 de7b08cf3292d6c46f7a6e954ece0a32c8e2f4d67bc5212ce755662b8abf50425d54c00e0601ba943a4a9835f32c3df63ef87d5655788510ed86f05dd485a963
diff --git a/dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild b/dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild
new file mode 100644
index 000000000000..65951f6a974b
--- /dev/null
+++ b/dev-ros/calibration_estimation/calibration_estimation-0.10.15.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Runs an optimization to estimate the a robot's kinematic parameters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/numpy[\${PYTHON_USEDEP}]")
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roslib[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/matplotlib[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/python_orocos_kdl[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/scipy[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/urdf_parser_py[\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"
+
+src_prepare() {
+ ros-catkin_src_prepare
+ sed -e 's/yaml.load/yaml.safe_load/g' -i src/*/*.py -i test/*.py || die
+}
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild b/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild
index d445cebc3fda..65951f6a974b 100644
--- a/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild
+++ b/dev-ros/calibration_estimation/calibration_estimation-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,12 +30,10 @@ DEPEND="${RDEPEND}
dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
$(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"
-PATCHES=( "${FILESDIR}/py3.patch" )
src_prepare() {
ros-catkin_src_prepare
sed -e 's/yaml.load/yaml.safe_load/g' -i src/*/*.py -i test/*.py || die
- 2to3 -w src/*/*.py src/*/*/*.py test/*.py || die
}
src_test() {