summaryrefslogtreecommitdiff
path: root/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild')
-rw-r--r--dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild b/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
index c83819a9fef4..d24d3f651478 100644
--- a/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
+++ b/dev-ros/calibration_estimation/calibration_estimation-0.10.14.ebuild
@@ -37,3 +37,8 @@ src_prepare() {
sed -e 's/yaml.load/yaml.safe_load/g' -i src/*/*.py -i test/*.py || die
2to3 -w src/*/*.py src/*/*/*.py test/*.py || die
}
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}