summaryrefslogtreecommitdiff
path: root/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtwebengine/qtwebengine-6.9999.ebuild')
-rw-r--r--dev-qt/qtwebengine/qtwebengine-6.9999.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
index 750f700160b2..bba17446d874 100644
--- a/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-6.9999.ebuild
@@ -236,19 +236,15 @@ src_configure() {
# for simplicity. Override with USE=custom-cflags if wanted, please
# report if above -march works again so can cleanup.
use arm64 && tc-is-gcc && filter-flags '-march=*' '-mcpu=*'
-
- # skia and xnnpack fail with clang-18 + some(?) -march=native while
- # can't reproduce with seemingly equivalent =skylake), needs more
- # looking into as there may be something odd going on (clang bug?).
- # Note that upstream Qt disallows custom *FLAGS on qtwebengine meaning
- # we are not supposed to pass -march=native in the first place.
- # TODO: try dropping this on major Qt and clang bumps
- # See also: https://groups.google.com/g/skia-discuss/c/DNW4oq3W2fI
- # (Transform_inl.h:769:21: error: AVX vector <snip> without 'evex512')
- use amd64 && tc-is-clang && [[ $(clang-major-version) -ge 18 ]] &&
- filter-flags -march=native
fi
+ # Workaround for build failure with clang-18 and -march=native without
+ # avx512. Does not affect e.g. -march=skylake, only native (bug #931623).
+ use amd64 && tc-is-clang && is-flagq -march=native &&
+ [[ $(clang-major-version) -ge 18 ]] &&
+ tc-cpp-is-true "!defined(__AVX512F__)" ${CXXFLAGS} &&
+ append-flags -mevex512
+
export NINJA NINJAFLAGS=$(get_NINJAOPTS)
[[ ${NINJA_VERBOSE^^} == OFF ]] || NINJAFLAGS+=" -v"