summaryrefslogtreecommitdiff
path: root/dev-qt/qtwayland/qtwayland-5.15.2-r15.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qtwayland/qtwayland-5.15.2-r15.ebuild')
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.2-r15.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-qt/qtwayland/qtwayland-5.15.2-r15.ebuild b/dev-qt/qtwayland/qtwayland-5.15.2-r15.ebuild
deleted file mode 100644
index ea619cd58e78..000000000000
--- a/dev-qt/qtwayland/qtwayland-5.15.2-r15.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-KDE_ORG_COMMIT=992833ca741efe8f533c61abfaf129a1d8bfcfee
-inherit qt5-build
-
-DESCRIPTION="Wayland platform plugin for Qt"
-SLOT=5/${QT5_PV} # bug 815646
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
-fi
-
-IUSE="vulkan X"
-
-DEPEND="
- dev-libs/wayland
- =dev-qt/qtcore-${QT5_PV}*:5=
- =dev-qt/qtdeclarative-${QT5_PV}*:5=
- =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=,X?]
- media-libs/libglvnd
- vulkan? ( dev-util/vulkan-headers )
- X? (
- =dev-qt/qtgui-${QT5_PV}*[-gles2-only]
- x11-libs/libX11
- x11-libs/libXcomposite
- )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- dev-util/wayland-scanner
-"
-
-src_configure() {
- local myqmakeargs=(
- --
- $(qt_use vulkan feature-wayland-vulkan-server-buffer)
- $(qt_use X feature-xcomposite-egl)
- $(qt_use X feature-xcomposite-glx)
- )
- qt5-build_src_configure
-}