summaryrefslogtreecommitdiff
path: root/dev-qt/qttools
diff options
context:
space:
mode:
Diffstat (limited to 'dev-qt/qttools')
-rw-r--r--dev-qt/qttools/Manifest4
-rw-r--r--dev-qt/qttools/qttools-6.7.1.ebuild154
-rw-r--r--dev-qt/qttools/qttools-6.7.2.ebuild2
3 files changed, 2 insertions, 158 deletions
diff --git a/dev-qt/qttools/Manifest b/dev-qt/qttools/Manifest
index 99818b5f9d8c..59d876214e71 100644
--- a/dev-qt/qttools/Manifest
+++ b/dev-qt/qttools/Manifest
@@ -1,7 +1,5 @@
-DIST qttools-everywhere-src-6.7.1.tar.xz 9016376 BLAKE2B 081a8a6fc838ee1dcee1b82cb46996ed246639a230f23d324fdcf2153c46ddbdd619505df0380ea20c7e9c668159dc49a061ecf57f27026b0a6fc7e6017d9b1c SHA512 5b21fc8a5f208615a3493a2ae24356705477c50f675cd7f29fc2eb7f7af5c2af7859068d26404ff8075d163adf0b0c4f267d14fa3f618de76ace8cd353a58a15
DIST qttools-everywhere-src-6.7.2.tar.xz 9019636 BLAKE2B c4324275adddefc2399ce4ff1305d285c9e4bc7fb6cebf6bd310573773ada5cf91f14561b855df685bdcce0a39897c3b9e0b62544083af2794d7eaaf35660146 SHA512 311467d0e6970711b4d984fe792d2b75609f38c04121073d5c3c34c682fcee89787f6982c886e62206a76b1f647de60e56510439b0288f8bd1ae21a2683a37cd
-EBUILD qttools-6.7.1.ebuild 4647 BLAKE2B df21c86f66baa7e799184c8e914191fb8ae2552d2f81608c90e149849eba154b9dbe80877e3de241bbd16f9f09b7b0df32a366907292a38dfa5fe8ed378acfb1 SHA512 cb09bae6d6728597c4f727165777ca1517413182341526f5d5b02898ed00c295bd118f13f376a6be0104a7b80df6503fb8d54373551820f48ea9f870fd45fe06
-EBUILD qttools-6.7.2.ebuild 4652 BLAKE2B eebd7864fe6b6c135e0a8a3ca82facb8596cd468c6cb7b9064ea2eb88d0340c9756c5c53cb29c8aff02553dc60665391d337bf470d0483e7d7e7dc6b789512d0 SHA512 0f106b67908d04dc45ef0954251dc699c2e4de63a223b03680fe295d2687830dfd2814bf7c0a5996fa847c4e48fa7e3d41fbe076f278e17cdab571fb91dc2f8a
+EBUILD qttools-6.7.2.ebuild 4646 BLAKE2B 4a77d671a5311fcd7e6170bc29764560993be958cc8ea58d6c31d8132372a5f65197a69acd3eee45d211cbbf95ee653849faa7d98a302db07f60e3b79b3e4912 SHA512 69930be9d05a6fbb10c616b8ec8b664d40428abbf516777ac5fcf85adc4a2ed39a82bcbfbb988aef8568ac0a3adcb4939fb89e531e90bbda97c751c6ff0e3e49
EBUILD qttools-6.7.9999.ebuild 4652 BLAKE2B eebd7864fe6b6c135e0a8a3ca82facb8596cd468c6cb7b9064ea2eb88d0340c9756c5c53cb29c8aff02553dc60665391d337bf470d0483e7d7e7dc6b789512d0 SHA512 0f106b67908d04dc45ef0954251dc699c2e4de63a223b03680fe295d2687830dfd2814bf7c0a5996fa847c4e48fa7e3d41fbe076f278e17cdab571fb91dc2f8a
EBUILD qttools-6.8.9999.ebuild 4975 BLAKE2B 35918fb023a017c7c2b958e5ec7990cf80cf45fed3d633b65e26314d62e597e7f19dc72d96b781f498e646f11a0c200c4510b2761c75df892b8a084d8707c823 SHA512 d2f528eabad3c58e41ec133a56715efa394d659cfac183477c8e41ae7c2afeca48cf81dbadf6f52ebff3da9f5f9a42aba761f57cbb436b02446d1d26fcb3cbca
EBUILD qttools-6.9999.ebuild 4975 BLAKE2B 35918fb023a017c7c2b958e5ec7990cf80cf45fed3d633b65e26314d62e597e7f19dc72d96b781f498e646f11a0c200c4510b2761c75df892b8a084d8707c823 SHA512 d2f528eabad3c58e41ec133a56715efa394d659cfac183477c8e41ae7c2afeca48cf81dbadf6f52ebff3da9f5f9a42aba761f57cbb436b02446d1d26fcb3cbca
diff --git a/dev-qt/qttools/qttools-6.7.1.ebuild b/dev-qt/qttools/qttools-6.7.1.ebuild
deleted file mode 100644
index b00cc875577e..000000000000
--- a/dev-qt/qttools/qttools-6.7.1.ebuild
+++ /dev/null
@@ -1,154 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LLVM_COMPAT=( {15..18} ) # see .cmake.conf for minimum
-LLVM_OPTIONAL=1
-
-# behaves very badly when qttools is not already installed, also
-# other issues to handle (clang tests flaky depending on version,
-# and 3rdparty/ tries to FetchContent gtest)
-QT6_RESTRICT_TESTS=1
-
-inherit desktop llvm-r1 optfeature qt6-build
-
-DESCRIPTION="Qt Tools Collection"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 arm arm64 ~hppa ~loong ~ppc ppc64 ~riscv ~sparc x86"
-fi
-
-IUSE="
- +assistant clang designer distancefieldgenerator gles2-only
- +linguist opengl pixeltool +qdbus qdoc qml qtattributionsscanner
- qtdiag qtplugininfo vulkan +widgets zstd
-"
-# note that some tools do not *require* widgets but will skip a sub-tool
-# if not enabled (e.g. linguist gives lrelease but not the GUI linguist6)
-REQUIRED_USE="
- assistant? ( widgets )
- clang? ( ${LLVM_REQUIRED_USE} )
- designer? ( qml widgets )
- distancefieldgenerator? ( qml widgets )
- pixeltool? ( widgets )
- qdoc? ( clang qml )
-"
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[network,widgets?]
- assistant? ( ~dev-qt/qtbase-${PV}:6[sql,sqlite] )
- clang? (
- $(llvm_gen_dep '
- sys-devel/clang:${LLVM_SLOT}=
- sys-devel/llvm:${LLVM_SLOT}=
- ')
- )
- designer? (
- ~dev-qt/qtbase-${PV}:6[xml,zstd=]
- zstd? ( app-arch/zstd:= )
- )
- qdbus? ( ~dev-qt/qtbase-${PV}:6[dbus,xml] )
- qml? ( ~dev-qt/qtdeclarative-${PV}:6[widgets?] )
- qtdiag? ( ~dev-qt/qtbase-${PV}:6[gles2-only=,vulkan=] )
- widgets? ( ~dev-qt/qtbase-${PV}:6[opengl=] )
-"
-DEPEND="
- ${RDEPEND}
- qtdiag? (
- vulkan? ( dev-util/vulkan-headers )
- )
-"
-
-pkg_setup() {
- use clang && llvm-r1_pkg_setup
-}
-
-src_configure() {
- local mycmakeargs=(
- # prevent the clang test as it can abort due to bug #916098
- $(cmake_use_find_package clang WrapLibClang)
- $(cmake_use_find_package qml Qt6Qml)
- $(cmake_use_find_package widgets Qt6Widgets)
- $(qt_feature assistant)
- $(qt_feature clang)
- $(qt_feature designer)
- $(qt_feature distancefieldgenerator)
- $(qt_feature linguist)
- $(qt_feature pixeltool)
- $(qt_feature qdbus)
- $(qt_feature qdoc)
- $(qt_feature qtattributionsscanner)
- $(qt_feature qtdiag)
- $(qt_feature qtplugininfo)
-
- # TODO?: package litehtml, but support for latest releases seem
- # to lag behind and bundled may work out better for now
- # https://github.com/litehtml/litehtml/issues/266
- $(usev assistant -DCMAKE_DISABLE_FIND_PACKAGE_litehtml=ON)
-
- $(usev designer -DQT_UNITY_BUILD=OFF) # fails to build (QTBUG-122634)
- )
-
- qt6-build_src_configure
-}
-
-src_install() {
- qt6-build_src_install
-
- if use widgets; then #914766
- use designer || use distancefieldgenerator || use pixeltool &&
- newicon src/designer/src/designer/images/designer.png designer6.png
-
- if use assistant; then
- make_desktop_entry assistant6 'Qt 6 Assistant' assistant6 \
- 'Qt;Development;Documentation' \
- 'Comment=Tool for viewing online documentation in Qt help file format'
- newicon src/assistant/assistant/images/assistant-128.png assistant6.png
- fi
-
- if use designer; then
- make_desktop_entry designer6 'Qt 6 Designer' designer6 \
- 'Qt;Development;GUIDesigner' \
- 'Comment=WYSIWYG tool for designing and building graphical user interfaces with QtWidgets'
- fi
-
- if use distancefieldgenerator; then
- # no icon, sharing with designer which fits letter-wise
- make_desktop_entry qdistancefieldgenerator6 'Qt 6 Distance Field Generator' designer6 \
- 'Qt;Development' \
- 'Comment=Tool for pregenerating the font cache of Qt applications'
- fi
-
- if use linguist; then
- make_desktop_entry linguist6 'Qt 6 Linguist' linguist6 \
- 'Qt;Development;Translation' \
- 'Comment=Tool for translating Qt applications'
- newicon src/linguist/linguist/images/icons/linguist-128-32.png linguist6.png
- fi
-
- if use pixeltool; then
- # no icon, not fitting but share with designer for now
- make_desktop_entry pixeltool6 'Qt 6 Pixel Tool' designer6 \
- 'Qt;Development' \
- 'Comment=Tool for zooming in the desktop area pointed by the cursor'
- fi
-
- if use qdbus; then
- make_desktop_entry qdbusviewer6 'Qt 6 QDBusViewer' qdbusviewer6 \
- 'Qt;Development' \
- 'Comment=Tool that lets introspect D-Bus objects and messages'
- newicon src/qdbus/qdbusviewer/images/qdbusviewer-128.png qdbusviewer6.png
- fi
-
- # hack: make_destop_entry does not support overriding DESCRIPTION
- find "${ED}" -type f -name "*.desktop" \
- -exec sed -i "/^Comment=${DESCRIPTION}/d" -- {} + || die
- fi
-}
-
-pkg_postinst() {
- use assistant &&
- optfeature "Qt documentation viewable in assistant" \
- 'dev-qt/qt-docs:6[qch]' #602296
-}
diff --git a/dev-qt/qttools/qttools-6.7.2.ebuild b/dev-qt/qttools/qttools-6.7.2.ebuild
index fd8e80ea6380..ac30a31faddf 100644
--- a/dev-qt/qttools/qttools-6.7.2.ebuild
+++ b/dev-qt/qttools/qttools-6.7.2.ebuild
@@ -16,7 +16,7 @@ inherit desktop llvm-r1 optfeature qt6-build
DESCRIPTION="Qt Tools Collection"
if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
fi
IUSE="